Start a New Discussion Ask a New Question

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Autosave to -folder doesn't work
  • Hello, can anyone help us with the following?

    We have a server-installation of PDF-Creator running with three different printers configured with there own autosave-settings.

    One of the departments requested the possibility to have the PDF's sepperated by user.
    Searching through the settings we came across the <username> tag.

    Our innitial version (1.00) was unable to use the username tag as a folder so we searched out the version that could.
    The serverinstallation has since been updated to v1.1.0 to be able to create username-folders, but that doesn't work to our satisfaction.

    Using the username tag in the filename, the correct user is added, but when we use the tag as a foldername it keeps returning administrator as the user.

    Is this a configuration error or a software error?

    How can we resolve the problem?
    We don't want to build a PDF-printer per user as we would get 10+ PDF-printers hogging the server.

    Thank U in advance for your reply...

  •  Tried out some other options.

    - The REDMOND-tags don't work (so why add them)
    - Found that the working tags are giving strange results...
       using the tag as a filename results in the remote user being mentioned
       using the tag as a foldername results in the local server user being mentioned
    - Tried v1.2.0 in a test environment and found the same results.

    Please fix this in the next version.

  • Hi InferisDCB,


    we are using PDFCreator in server mode and it works fine. PDFCreator is started with domain-admin rights and we are using the redmon tag <REDMON_USER>.


    Can you describe the strange results a little bit more detailed?


    Best regards,

    Frank Team pdfforge
  • Thank You for your reply,

    We have a Windows 2003 serverinstallation (v1.1.0) managed by the domain administrator logged in on the physical server.
    Not using RDP how we normally manage the server; as this stops the manager from working when we log of.

    - When we use the <redmond_user> tag, we get no result back
    - When we use the <username> tag as a filename, the accountname of the enduser is added as the username. In my case "danny.bertisen".
    - When we use the <username> tag as a foldername, the accountname of the serveruser is added. In the current serverinstallation this is "administrator". This was backed up by a Windows XP test-installation.

    On a testprinter on the mentioned Server (running PDFCreator v1.1.0) and in a test installation on WinXP (using PDFCreator v1.2.0) we get the same results.

    Waiting for your reply,

    Danny Bertisen

  • Hi InferisDCB,

    We are now also using the version 1.1.0 with server installation and also it works fine.

    And I just registered for posting for you.

    We just enabled the "Auto-save" and user the directory "F:\PDF\<REDMON_USER>" for auto-save, and once the users print with the PDFCreator, they can find the pdf file they print in the folders with their name under the path: F:\PDF.

    If it still  not work, how about reinstalling it?

    Hope you can solve it.

    Best regards,

     

     

  •  Thank U Shakodo, you just hinted at something I didn't test yet.

    We set the serverisntallation to autosave to a networkdestination. (example: \\server-01\PDF_files\)
    I now made a networkdrive and added the savepath as a local directory (example: Y:\PDF_files\); this resolved the problem. Now the Redmond_user tag works like a charm.

     

    Thank You all for your help.

    Greets, Danny

  •  HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\PDFCreator\Program

     

    Auto-Save value in there

  • thanks, this worked for us using v1.1.0 and using the redmon tags as you mentioned. ;-)