2.5 PDF after opening does not open the default reader


#1

Hello. I installed version 2.5.1. After the press continues to offer the PDF architect instead of the default player that is properly associated in W7 programs.
I remade several times the association, also installed Architect but nothing changes.


#2

Hi,

There is a checkbox in the “open document” action that you need to uncheck if you want to use your default pdf viewer:


#3

Hi, I have the same problem as @fantesma since I installed version 2.5.1 (and 2.5.2). My default reader is Acrobate Reader and the option you shown is unchecked in “profile settings”, but it’s still trying to open pdfs I created with PDF Architect.


#4

Hi
In Windows 10, with the last version 2.5.3 the problem still persists. If is selected in the Actions “open document” and not “open with pdfarchitect”, at the end of the printing a window appears and the document is not opened by Adobe Reader. I would know the last version without this problem to reinstall it.
Thank you


#5

Hi,

I can’t reproduce this problem when setting Adobe Reader DC as default viewer on Win 10 it works correctly. If you have other versions of Adobe Reader installed, they might register differently and therefore PDFCreator might not be able to detect them. Unfortunately there are now several different ways to register default applications in Windows and we are having trouble finding a way to detect this properly in all cases. .NET has a native method for opening a file with the associated default application which should handle this, but even this doesn’t work properly anymore.

Best regards,

Robin


#6

Thank you for the answer.
I tried also to uninstall and reinstall Adobe Reade but the trouble still persists with PDFCreaor 5
The problem is not on Adobe Reader but on PDFCreator 5: I’ve reinstalled the version n. 2.4.1 and it works normally; after printing the file is open by Adobe Reader.

Best regards
Mario


#7

Hi Mario,

it is more complicated than this. It works with PDFCreator 2.4.1 because it uses a different method to lookup the default application. While this fixes the situation on your system, we had the exact problem reported by other users for PDFCreator 2.4.1, so we tried to fix them, but still didn’t manage to find a method that works for all supported OS.
You are correct, it isn’t a problem in Adobe Reader, but rather a problem with .NET and Windows (and since PDFCreator uses .NET, also PDFCreator). Hopefully we will be able to find a method which works for everybody again soon.

Best regards,

Robin


#8

Thank you and best regards

Mario


#9

The same problem with Pdfcreator 3!!!


#10

Hi,

unfortunately, there is no obvious way for us to fix this until MS fixes it in .NET/Windows.
We will add a feature which will enable users to specify their default applications for opening and printing supported file types with one of the next PDFCreator updates. You can work around the issue in any of the current releases by using the “Run Script” action instead (and pointing this to your preferred PDF viewer). If you’d like to try this I can link a thread with more info.

Best regards,

Robin


#11

Thank you. Hope this feature will colse this forum page!


#12

Thank you in advance for sharing the link to script.

M$ might never fix this or take a very long time to do anything about it.
PDF Viewer is now inside “Edge”

We that prefer Acrobat Reader and had to manually override the default Edge setting.

Looking forward having a easy solution (check box?)


How to make a PDF file without a PDF Architect installation prompt?
#13

Hello. Where can I find this script your referring to please?


#14

Hi,

there is no script for this, I suggested using the script action in PDFCreator (and in this case, the “script” will be the executable of your default PDF viewer, e.g. Adobe Reader.exe). The settings for the script action are located in profiles->advanced in PDFCreator 3. In PDFCreator 2.x, the settings are located in profile settings->actions->run script.
In most cases it is enough to specify the path to your readers executable and no additional parameters are required.

Best regards,

Robin


No application is associated to open pdf file?
#15

Ah ok I misread the post. Thanks


#16

Thank you very much, Robin.
With the script as you suggested Acrobat runs normally.

Best regards
Mario


#17

Which script? if i insert “AcroRd32.exe” in “script file” problem remains


#18

Hi,

inserting AdobeRd32.exe into “script file” should do the trick, did you additionally disable the “open document” action?
This might be required in some versions of PDFCreator. We have hopefully found a way to repair all this for PDFCreator 3.1.

Best regards,

Robin


Standard-Anwendung zum Öffnen von PDF-Dokumenten in V 2.4.1