Additional profile and document merge appear to be broke in PDFCreator ver. 3.1.2


#1

Hello.
I created a security profile that wouldn’t allow the user to copy/modify/fill the .pdf document created with PDFCr but the resulted documents have no security, please see attached profile and properties of the resulted ,pdf doc.
Document merge doesn’t work, no matter how many files I want to consolidate when I’m done selecting the pages and choose to print the result it only prints the first page; I also have no possibilities to manipulate the files intended to be merged prior to printing
Using Win 10 Pro 64bit and PDFCreator ver. 3.1.2 - PDFArchitect is NOT installed; Ver. 3.1.2 was installed after fully uninstalling the previous version.
Do you have a place to download older versions? I used PDFCr for almost 4 years and used all of the above features.
Please help, thank you in advance


#2

Hi @Kaitlin

  1. You would need to set an “owner password (for editing)” using “Set Passwords” to enable the document restrictions.

  2. Please test merge function of PDFCreator again using Settings > Debug > Print Windows Test Pages. How does this overview look like at your end?

  1. Older version of PDFCreator Free can be downloaded here:
    http://download.pdfforge.org/download/pdfcreator/list

Kind regards
Sascha


#3

Hello Sascha and thank you for your swift reply.
I managed to verify and indeed I had no password configured but once I added one and restarted the app indeed the result was a secured document.
I also tried your suggestions for merging 2 docs but I was not successful, I have a a busy period and only could spend 5 minutes for this attempt: will spend some more time in the following days and will come back with the results.
I must say that using the Merge function is one of my least favorites of pdfCreator, I always felt that the steps expected are somehow counter-intuitive and had to try several times until I got a merged document even when the app was performing as expected.
Thank you.


#4

Hello.
I can’t make any sense out of the document merge feature, I tried to follow you instructions but that didn’t worked, please see video: app box com/s/ followed by gjyvqxkp3ghijgr400jshwj57j9clxv2 -(please copy and join bold text and replace the spaces in the first group with “.” ) - I’m too new to post plain links here or in private message
Thank you


#5

Hi,

thanks for the video, it seems something unexpected is happening on your end, I wasn’t able to reproduce the issue here.
Usually, after clicking on merge you should more or less instantly get the following merge window:


In general, you can first print all the documents you’d like to merge to PDFCreator (without pressing any button on the PDFCreator GUI) and at the end use the merge button.
Please set the logging level to “trace” inside the PDFCreator application settings, reproduce the issue and send the resulting log to support(at)pdfforge.org, it should help to find the cause of the issue more quickly.

Best regards

Robin