Automatic save to temp folder not working


#1

Hey guys,

My company uses PDFCreator to print documents from our ERP, and automatically attach the generated PDF to a new Outlook email.

Up to now, we’ve been using 1.7.0 to do this, but I’m looking to migrate us to 2.5.3.

My issue is that I’d like to eliminate the step where after printing, the pdfcreator prompt pops up, and the user needs to click on email to actually attach to the email.

This seems to be possible using automatic saving, however I don’t seem to be able to use “” as the auto save directory like with 1.7.0. I’ve tried using “%USERPROFILE%\Local Settings\Temp” but run into permission issues. The PDFCreator.log ends up with errors like this:

2017-09-14 13:35:25.9201 [Error] pdfforge.PDFCreator.Conversion.Ghostscript.Conversion.GhostscriptConverter.DoConversion: There was an unexpected error while converting the Job C:\Users\u3508\AppData\Local\Temp\PDFCreator\Spool\10-9E53E5756CC14DAEB714246203A055BD.inf: System.UnauthorizedAccessException: Access to the path ‘%USERPROFILE%\AppData\Local\Temp’ is denied.

This is how it was configured back in the day:

Do you have any suggestions for configuring a temp directory? This is going to be deployed to many users with PDQ Deploy, so I’m hoping we can use a local variable rather than having to visit every computer to configure their printer settings.

Thanks


#2

Hi,

you can still use environment variables in the current releases, but the syntax has changed to e.g. <Environment:TEMP> to more clearly distinguish our own tokens form the environment variables.
Here is a list and additional information on the currently available tokens:
http://docs.pdfforge.org/pdfcreator/latest/en/pdfcreator/using-pdfcreator/tokens/

Best regards,

Robin


#3

Thanks Robin, you are the man