How to skip the print dialog with Hot Folder


#1

I have the purchased the license for PDF Creator and I am having issues with the Hot Folder option. It worked correctly then stopped. I have removed it and reinstalled it etc. It works but each time it shows me the Print Dialog box then it auto saves it correctly. How do I fix it so the print dialog does not show up and it converts the file automatically.


#2

Hi,

please have a look at the HotFolder settings to see which PDFCreator profile your current configuration is using.
Afterwards, run PDFCreator and ensure the saving mode is set to “automatic” in the profile which is used by the HotFolder.
Usually the HotFolder wizard should handle all this automatically, but you can always manually change the profile settings from inside PDFCreator.

Best regards

Robin


#3

I have done all of that, I have read the help file numerous times and uninstalled and reinstalled the software as mentioned in the help file. Apparently it is somehow related to what is printed and how it is formatted. For instance if I try to print a HTML file I don’t get the prompt provided there is no photo in the file. But that is with IE, as my default browser. with Google I always get it. Finally I gave up and tried wkhtmltopdf as all I wanted was to convert a HTML file to PDF. This tool so far as worked well.


#4

Hi,

do you get the Windows print dialog, or a PDFCreator print dialog?
If an application registered its print/print to shell verbs incorrectly, this could cause a print dialog to pop up regardless of any HotFolder settings. This would also explain why it it relates on your default browser setting.
In most cases this can only be fixed by manually editing registry entries or using a different default application.

Best regards

Robin


#5

Its the Windows Print Dialog. What would be the registry entries to edit? Is it per application? Do they always have something in common to look for?


#6

Hi,

generally this is all controlled per filename extension in the HKEY_CLASSES_ROOT section of the registry.
Here is a link to a thread explaining how this generally works (with an example for the .docx filetype):


On my machine the settings controlling the HTML print behavior are located under HKEY_CLASSES_ROOT\htmlfile\shell\print / HKEY_CLASSES_ROOT\htmlfile\shell\printto
Setting the “print to” command to
“C:\WINDOWS\system32\rundll32.exe” “C:\WINDOWS\system32\mshtml.dll”,PrintHTML “%1” “%2” “%3” “%4”
instead of whatever it is when Chrome is default should do the trick.

Best regards

Robin


#7

Strange, I don’t have any of those keys. But I do have that value in
HKEY_CLASSES_ROOT\IE.AssocFile.SVG\shell\printto\command so I assume that is what IE is using. I will just use the other utility for conversion. I have used PDF Creator for years as for some reason Adobe’s conversion used to lock up my system on occasion and PDF Creator never has, plus it allows me to create multi-page tiffs. Thank you for all of your help on this.


#8

Hi,

what I posted was a bit of a short version.
First, you will need to find out the name registered for the extension, which is the default value in HKEY_CLASSES_ROOT.html (for me it is htmlfile).
Then HKEY_CLASSES_ROOT\htmlfile\shell\printto\command will contain the command.

If the default value for HKEY_CLASSES_ROOT.html is e.g. HKEY_CLASSES_ROOT\ChromeHTML on your machine, the path for the command would be HKEY_CLASSES_ROOT\ChromeHTML\shell\print to\command

Of course using the other utility might be easier/just as good, I mainly added the info in case anybody else comes across this and needs a way to fix the registry entries.

Best regards

Robin