Page orientation problem - drop-down menu


#1

Dear Sir/Madam,

Whenever I use the drop-down menu (right click on a file) to convert a JPEG file into PDF, the final PDF file is upside down. I’m already very tired of using PDF Architect to correct this. I’ve been waiting for a correction for a long time, but I’m now in version 2.5.1 (the latest) and the problem persists. In the page orientation setting, I’m using “auto detect”.

Therefore, I would like to suggest that pdfforge creates a “NO ROTATION” setting, as it seems that the auto detection doesn’t work properly. Please, create this setting, so the software will never rotate files, it doesn’t matter if they are in landscape or portrait orientation.

If this information is important, I’m using Windows 8.1.

Best regards,

H.


#2

Hi,

this is technically a lot more complicated than it sounds; the auto-detection is supposed to work the way you describe (not rotate the document at all), but this doesn’t work very well especially if no text is present in the image/document you are converting. onsider a hardware printer, where the paper will (usually) always come out with the short end first and if the content is landscape, you physically need to turn the page to view the content properly, same goes for upside down. Which application are you printing from? Have you tried setting the option to portrait or landscape manually to see if it helps?

Best regards,

Robin


#3

Dear Robin,

Answering your questions:

  1. As I had said, I’m using “the drop-down menu (right click on a file) to convert a JPEG file into PDF”. So I’m not using any particular application; only Windows 8.1 and PDF Creator.

  2. I haven’t tried “setting the option to portrait or landscape manually”, because if I set it to portrait, then I will have to rotate the final PDF if the original image was landscape (and vice-versa); or then I will have to change this setting (portrait/landscape) every time I have a file in a different orientation, which will be annoying (and extra work) as well.

Therefore, in my opinion it still seems that the best solution is pdfforge creating a “NO ROTATION” setting, so that the application will never rotate files when converting to PDF; as a consequence, the PDFs will always have the same orientation as the original files. That means no problem and no extra work for us, users.

Best regards,

H.


#4

Dear Droit,

1.Using the context menu of PDFCreator will look up the “print” or “print to” command associated to that file type (in this case, jpeg) and then execute the command to have the file printed to the PDFCreator printer; this always involves a third application handling the printing. If you right click onto a JPEG and select “print” instead of “convert with PDFCreator”, which application opens?
2. You can easily setup a “portrait” and a “landscape” PDFCreator pinter to deal with this.
First create two profiles which a landscape and a portraint setting. Then go to the PDFreator application settings and create 2 new printers and assign the freshly crated profiles to them. Now you can select which orietation to use by selecting the corresponding printer during the print job.
A “no rotation” option is not possible in our case; we use Ghostscript to convert the printing data and can either have it automatically detect the orientation (which as you have experienced often fails), or tell it which of the 4 possible orientations to use (portaint, landscape, upside down, seaside) in which case we would need to properly detect the orientation ourselves.
It might seem simple to just “not rotate the page” but it is currently not possible and also wouldn’t really solve the problem, as applications might actually print upside down, again think of how printing on paper works and that virtual printers share some of the same rules. They know to start printing from e.g. top left to bottom right of the page, but have no idea on how the user will view the content in the end.

Best regards,

Robin