PDF Architect gibt Dateien nicht frei


#1

Hallo,

um noch mal auf den Post 8683 (darf hier als neuer User keine Verweise posten!?) zurückzukommen:

Wenn wir eine Datei im PDF Architect (aktuelle Version) geöffnet hatten, lässt diese sich im Windows Explorer anschließend nicht löschen. Die Meldung lautet: “Die Aktion kann nicht abgeschlossen werden, da die Datei n PDF Architect geöffnet ist. Schließen Sie die Datei und wiederholen Sie den Vorgang.”

  • Wir haben zuerst die Datei geschlossen,
  • dann die Liste der zuletzt geöffneten Dateien gelöscht,
  • anschließend PDF Architect geschlossen.

Vermutlich liegt es daran, dass wir im PDF Architect die Option “schnelleren Start” aktiviert haben. Dennoch sollten geschlossene Dateien auch freigegeben werden (nach zehn Minuten ist das immer noch nicht der Fall).

Viele Grüße,
Anke


#2

Hallo Anke,

in der Tat können neue User zunächst keine Verweise oder Bilder posten, weil sich der Spam sonst nur sehr schwer in den Griff bekommen lässt. Ich habe Deinem Account nun die entsprechenden Rechte gegeben, falls Du die Funktionen zukünftig nutzen möchtest.
Hast Du Version 4.1.05 installiert? Ich konnte das Problem hier nicht reproduzieren (schneller Start war an). Die Dateien ließen sich hier direkt nach dem schließen löschen.

Beste Grüße

Robin


#3

Hallo Robin,

Dank für die Freischaltung.

Ja, Version 4.1.05 64-bit unter Windows 10 Pro (aktuell). Nachdem ich den Ruhezustand (schneller Start) wieder deaktiviert hatte, ließ die Datei sich problemlos löschen. Was kann ich tun, um bei der Fehlersuche zu helfen?

Viele Grüße,
Anke


#4

Ich weiß nicht warum, am System wurde nichts geändert, aber heute klappt es mit dem Löschen, auch bei wieder angeschaltetem Schnellstart …

Vielen Dank nochmal!


#5

Tja, dieses Thema habe ich wohl doch etwas vorschnell als gelöst markiert. Aktueller Fall:

  1. Zwei im Architect geöffnete Dateien zusammengefügt.
  2. Die beiden Ursprungsdateien im Architect geschlossen.
  3. Versuch, die “zusammengefügt”-Datei unter dem Namen einer der Ursprungsdateien zu speichern, schlägt fehl, weil die Datei noch “gesperrt” ist.
  4. Nachdem die Datei anschließend erfolgreich unter einem neuen Namen gespeichert wurde, werden die beiden Fehlermeldungen immer noch angezeigt (irreführend).

PS: Wenn man nachträglich weiteren Inhalt in ein bestehendes PDF drucken will, wäre es ganz toll, wenn der Dialog nicht nur hieße “Datei ersetzen?”, sondern wenn man auch hier die Wahl bekäme zwischen “Datei ersetzen”, “Am Anfang der Datei hinzufügen” oder “Am Ende der Datei hinzufügen”.

EDIT:
Ups, jetzt hatte ich die zusammengefügte Datei also unter einem neuen Dateinamen gespeichert, PDF Architect geschlossen, und will die beiden Urpsungsdateien im Explorer löschen - geht wieder nicht. “Schnellstart” ist aktiv. - Ich nehme an, die Schnellstartoption schreibt was in die Registry? Das wäre m.E. eine Erklärung für unterschiedliches Verhalten vor und nach einem Systemneustart …


#6

Inzwischen sind ja ein paar Tage vergangen und es gab ein Update auf Version 5.0.28.34044. Leider hat sich am Proble der Nichtfreigabe nichts wesentlich geändert.

Wenn ich Datei A und B bearbeite, diese schließe, die Vorschauen lösche und Datei C öffne, dann kann ich Dateien A und B im Explorer löschen oder verschieben, vorher geht das nicht. Das sind weiterhin eine Menge “überflüssiger” Klicks …

Bei dieser Gelegenheit und da das Thema, denke ich, sehr ähnlich ist: Beim Speichern von Dateien und vor allem auch beim Drucken über den PDFCreator würde ich mir wünschen, dass automatisch das zuletzt verwendete Verzeichnis im Dialogfenster geöffnet würde - so effizient, wie von anderen Windows-Anwendungen gewohnt.


#7

Hallo Katswiri,

das Problem im PDFCreator ist in Version 3.0.2 gelöst.
Das Freigabeproblem konnte ich so nicht nachvollziehen, die Dateien lassen sich auch dann löschen, wenn diese gerade in der Vorschau angezeigt werden. Richtig ist, dass die Dateien nicht gelöscht oder verschoben werden können, solange diese im PDF Architect geöffnet sind.

Beste Grüße

Robin


#8

Gehen Sie doch mal wie folgt vor:

  1. Öffnen Sie zwei Dokumente im PDFA.
  2. Gehen Sie auf Erstellen - Zusammenfügen - geöffnete Dokumente - und speichern Sie die zusammengefügte Datei.
  3. Schließen Sie alle drei Dokumente im Architekt, lassen Sie die Vorschaubilder bestehen und minimieren Sie das PDFA-Fenster.
  4. Löschen Sie eine der beiden Einzeldateien, die Sie für die Zusammenfügung verwendet haben.

Diese lassen sich bei uns nicht löschen, die zusammengefügte neue Datei dagegen schon.


#9

Hallo Anke,

vielen Dank für die detaillierte Anleitung, so konnte ich das Problem nachvollziehen. Ich hatte den Thread nicht nochmal komplett gelesen, da stand das meiste ja auch schon drin, bitte entschuldige. Das Problem tritt unabhängig von der “Schneller Start” Option auf.

Unsere Entwickler werden sich das Problem ansehen und hoffentlich bald eine Lösung dafür finden können. Der Entscheidende Punkt ist wohl das Zusammenfügen.

Beste Grüße

Robin


#10

Hi Robin,

gibt’s hier was Neues - oder wurde das schon gelöst, ohne dass ich es bemerkt habe?

Gruß,
Anke