Printerhelper stopped working error message during setup


#1

I have tried installing pdf creator 2.5.1. Windows 7 pro 32 bit. Setup fails, error message displayed: “printerhelper stopped working”. pdfcmon ports exist in port list, but are not installed as printers. When I run printerhelper I get a cmd screen that appears and then closes. I have tried many different solutions as described in many other topics, but none have worked. I tried to upload the setup Notepad log file the was created by your program but your forum blocked it.


#2

Hi,

sorry for the trouble, I have given your account additional rights to allow the upload, it is disabled by default to prevent spam.

Best regards,

Robin


#3

Hi Robin,

Thank you for responding. I have tried uploading the setup log txt file and it is still blocked. The message says that only jpeg type files are allowed, so I have copied and pasted the log into this message as follows:
----- Setup - Start: 2017-04-06 07:13:47 -----
Install PDFCreator: 1.6.2
InstallerDirectory: C:\Users\lcampo\Downloads
X64: no

Start AnalyzeCommandlineParameters
Parameter /VERYSILENT: false
Parameter /SILENT: false
Parameter /FORCEINSTALL: false
Parameter /REMOVEOPTIONS: false
Parameter /DONTINSTALLPRINTERS: false
Parameter /EXPERT: false
No Parameter /LoadInf
No Parameter /SaveInf
No Parameter /REGFile
No Parameter /PPDFile
No Parameter /Printername
End AnalyzeCommandlineParameters

WindowsVersionNumber: 6.1.7601
Silent installation: false
GUITS (7000, 50): 141
Update: 0
Installed PDFCreator version: 0.0.0
Installed PDFCreator version is lower 1.5.1 = true
nationCode: 244
InstallPDFCreatorPrinter = true
OS: 1
AppPath: C:\Program Files\PDFCreator
InstalledPDFCreatorVersion: Not installed
DontInstallPrinters: false
SPT: false

Printerstatus before installing:
Spooler service: is running
Printermonitors [3]:
WSD Port
Standard TCP/IP Port
Adobe PDF Port

Printerports [4]:
USB002
USB001
SHRFAX:
Desktop*.pdf

Printerdrivers (Windows 4.0) [0]:

Printerdrivers (Windows NT x86) [7]:
Send To Microsoft OneNote 2010 Driver
PDF Architect 5 Driver
Microsoft XPS Document Writer
Microsoft Shared Fax Driver
Canon MF4100 Series UFRII LT
Canon MF4100 Series (FAX)
Adobe PDF Converter

Printerdrivers (Windows x64) [0]:

Printerdrivers (Windows IA64) [0]:

Printerdrivers (Windows NT Alpha_AXP) [0]:

Printers [6]:
Send To OneNote 2010
Microsoft XPS Document Writer
Fax
Canon MF4100 Series UFRII LT
Canon MF4100 Series (FAX)
Adobe PDF

Printerdriver-Directory (Environment: Windows 4.0):
Result: Success = C:\Windows\system32\spool\DRIVERS\WIN40

Printerdriver-Directory (Environment: Windows NT x86):
Result: Success = C:\Windows\system32\spool\DRIVERS\W32X86

Install printerport:
Portname : pdfcmon
Result: Success

InstallMonitor:
Monitorname : pdfcmon
Environment : Windows NT x86
Result: Success

Install printerdriver for Win2kXP2k3 (32bit):
Drivername : PDFCreator
Environment : Windows NT x86
Result: Error 5 = Access is denied

InstallPrinter:
Printername: PDFCreator
Drivername : PDFCreator
Portname : pdfcmon
Result: Error 1797 = The printer driver is unknown

No printer has been installed!

Printerstatus after installing:
Spooler service: is running
Printermonitors [4]:
pdfcmon
WSD Port
Standard TCP/IP Port
Adobe PDF Port

Printerports [4]:
USB002
USB001
SHRFAX:
Desktop*.pdf

Printerdrivers (Windows 4.0) [0]:

Printerdrivers (Windows NT x86) [7]:
Send To Microsoft OneNote 2010 Driver
PDF Architect 5 Driver
Microsoft XPS Document Writer
Microsoft Shared Fax Driver
Canon MF4100 Series UFRII LT
Canon MF4100 Series (FAX)
Adobe PDF Converter

Printerdrivers (Windows x64) [0]:

Printerdrivers (Windows IA64) [0]:

Printerdrivers (Windows NT Alpha_AXP) [0]:

Printers [6]:
Send To OneNote 2010
Microsoft XPS Document Writer
Fax
Canon MF4100 Series UFRII LT
Canon MF4100 Series (FAX)
Adobe PDF

IC:1|1.6.2|0|en|b4

— Systeminformation - Start —
Windowsversion: 6.01.7601
WinDir: C:\Windows
Win64: false
ProcessorArchitecture: X86
.Net 2.0: true
.Net 2.0 regasm.exe:C:\Windows\Microsoft.NET\Framework\v2.0.50727\RegAsm.exe
SystemDir: C:\Windows\system32
TempDir: C:\Users\lcampo\AppData\Local\Temp
CurrentDir: C:\Windows\system32
Computername: SPAREHOMEPC
Username: lcampo
UILanguage: 1033
Internet Explorer version: 9.11.9600.18617
Path: C:\Windows\system32;C:\Windows;C:\Windows\System32\Wbem;C:\Windows\System32\WindowsPowerShell\v1.0;C:\PROGRA~1\CONDUS~1\DISKEE~1;C:\Program Files\Lenovo\Access Connections
C:\Windows\system32\Wbem\framedyn.dll: NOT found
framedyn.dll: found in path
— Systeminformation - End —

— Environment - Start —
ACPath=C:\Program Files\Lenovo\Access Connections
ALLUSERSPROFILE=C:\ProgramData
APPDATA=C:\Users\lcampo\AppData\Roaming
CommonProgramFiles=C:\Program Files\Common Files
COMPUTERNAME=SPAREHOMEPC
ComSpec=C:\Windows\system32\cmd.exe
FP_NO_HOST_CHECK=NO
HOMEDRIVE=C:
HOMEPATH=\Users\lcampo
LOCALAPPDATA=C:\Users\lcampo\AppData\Local
LOGONSERVER=\SPAREHOMEPC
NUMBER_OF_PROCESSORS=2
OS=Windows_NT
Path=C:\Windows\system32;C:\Windows;C:\Windows\System32\Wbem;C:\Windows\System32\WindowsPowerShell\v1.0;C:\PROGRA~1\CONDUS~1\DISKEE~1;C:\Program Files\Lenovo\Access Connections
PATHEXT=.COM;.EXE;.BAT;.CMD;.VBS;.VBE;.JS;.JSE;.WSF;.WSH;.MSC
PROCESSOR_ARCHITECTURE=x86
PROCESSOR_IDENTIFIER=x86 Family 6 Model 15 Stepping 13, GenuineIntel
PROCESSOR_LEVEL=6
PROCESSOR_REVISION=0f0d
ProgramData=C:\ProgramData
ProgramFiles=C:\Program Files
PSModulePath=C:\Windows\system32\WindowsPowerShell\v1.0\Modules
PUBLIC=C:\Users\Public
SystemDrive=C:
SystemRoot=C:\Windows
TEMP=C:\Users\lcampo\AppData\Local\Temp
TMP=C:\Users\lcampo\AppData\Local\Temp
TSMPATH=C:\Program Files\ThinkPad\UltraNav Utility
TVT=C:\Program Files\Lenovo
USERDOMAIN=SPAREHOMEPC
USERNAME=lcampo
USERPROFILE=C:\Users\lcampo
windir=C:\Windows
windows_tracing_flags=3
windows_tracing_logfile=C:\BVTBin\Tests\installpackage\csilogfile.log
— Environment - End —

----- Setup - End: 2017-04-06 07:16:27 -----

Hope this helps.

Thanks, LC


#4

OK. I fixed it. It took two days to figure it out but the problem was that the pdfcreator printer driver was denied access to load because the local security permissions were set to only allow administrators. I Googled around and found this: https://technet.microsoft.com/en-us/library/bb457115.aspx. After changing the permissions for loading printer drivers, I uninstalled again, reinstalled and BINGO - it works…yeah!!!


#5

Hi,

sorry for not responding in time and thank you very much for sharing the solution with us.

Best regards,

Robin