Runtime Error (at 428:38): Could not call proc


#1

Hi,

i tried to upgrade to 3.0.1. After starting the install-file i got the following message/error:

Runtime Error (at 428:38): Could not call proc.

I appreciate any help

Thank you Stefan


#2

Hi Guys,

is there any chance to get a quick answer? I am really awaiting a solution for our problem, cause we really need the pdf creator for our work - even as far as I remember, we deffinetly paid for the license and as far as i am able to remember, there was a point “support included” when we bought the license!

So please help as -> Thank you!


#3

WoW is this the kind of support, paying customers can expect? Thank you for nothing… :confused:


#4

I’m getting the exact same error with 3.0.2 terminal server version.
It installed fine on 4 of 5 TS servers and the last one gives me this error.

restarted the server didn’t help.
running as administrator doesn’t help

now we need your help


#5

Hi,

sorry for the long wait, unfortunately this has been overlooked for some most of the time.Emails sent to the support address included in the welcome mail you received upon purchase will get answered much faster than forum posts. We try to also keep track of all the form posts, but the channel for priority is email.

Please try to uninstall PDFCreator manually before installing the new version. Do you happen to use Kaspersky Endpoint protection? Another user has reported he needed to turn this off in order to get rid of the error.

Best regards,

Robin


#6

We have the the same issue on 3 terminal servers running Windows 2012r2.

  • Deinstallation of the old version does not fix the issue
  • Rebooting the server doesn’t fix the issue
  • Temp. deactivation of AV software doesn’t fix the issue
  • Eventvwr does not contain any helpful information

Please advice asap, thx!


#7

As previous Posters wrote. Deinstallation does not bring the solution for our Problem.


#8

Hi,

sorry for the trouble.
Once everything is uninstalled, please try running the .exe setup with the parameter /ForceInstall.
Have you tried installing from the MSI package? The problem might be exclusive to the InnoSetup/.exe setup.
If you’d like to use the MSI, please keep in mind it needs to be run from an administrative console and requires the licensekey as parameter: http://docs.pdfforge.org/pdfcreator/3.0/en/pdfcreator/installing-pdfcreator/msi-installer/

Best regards

Robin


#9

Hi Robin

I tried running MSI installaer using an administrative console:

PDFCreator-Terminal-Server-3_0_2_8659-Setup_x64.msi LICENSEKEY=XXXX-XXXX-XXXX-XXXX-XXXX-XXXX ADDLOCAL=MAINPROGRAM

This one gives the error ‘There is a problem with this Windows Installer package. A program run as part of the setup did not finish expected. Contact your support personnel or package vendor’

Denis


#10

Hi Denis,

did you als try to install the .exe Setup with the parameter /ForceInstall?
Regarding the MSI, the only thing I can currently think of which would cause this error is either a connection problem between the machine and our license server (e.g. connection blocked by firewall) or a previous version of PDFCreator still being present on the machine (which was installed with an .exe setup, the MSI can’t automatically remove non MSI installations).

Best regards,

Robin


#11

Hi Robin

Yes, running the .exe /ForceInstall comes up with the same error msg “Runtime Error (at 428:38): Could not call proc.”

Regards
Denis


#12

Hi Denis,

I hope you received my email by now.

We have another workaround for the issue:

  1. Make sure you have a backup of your settings. (Guide: Export Settings)
  2. Uninstall PDFCreator
  3. Restart PC/Server
  4. Delete the PDFCreator program folder
  5. Delete the following registry key: Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall{0001B4FD-9EA3-4D90-A79E-FD14BA3AB01D}
    (Make sure the key you’re about to delete is the PDFCreator key)
  6. Restart PC/Server
  7. Install PDFCreator with /ForceInstall

Best regards,
Flo


#13

Hi,

it seems the actual cause for this is a problem with the license check during the setup.
If you are still encountering this issue, please login to our license server license.pdfforge.org to revoke the activation count for your license and delete the license and LSA entries from HKEY_LOCAL_MACHINE\SOFTWARE\pdfforge\PDFCreator in your registry.
Sorry for the trouble, we will fix this on our end as soon as possible.

Best regards,

Robin


#14

I only can block the license of all server… So please block my license for one server or find another solution where the customer do not have to do handicrafts…


#15

Hi,

there is no need to block any server, revoking will only reset the activation counter in our license server to ensure the currently used machines can activate properly. I have revoked the activations for your license.

Best regards,

Robin