Turning of ads for PDF Architect


#1

I’m all for supporting open source so I purchased the license for PDFCreator and to have it turn off the ads (as “advertised”) This includes ads for PDF Architect!

I do not want or need PDF Architect so it was deselected during the installation process.

When I create a PDF using PDFCreator with the option to open the file upon completion it gives me the message “No application is associated to open PDF files”

That is not true! the computer is set to open PDFs by default using Adobe Acrobat (full / not free version)

Turning off the automatic opening of the file defeats the time saving purpose and getting the PDF Architect advertising message is annoying, time wasting and it is a false message.

How can PDF Creator be set to open the files it creates automatically without installing PDF Architect or getting the annoying message?

Thank you.

Ric


#2

Hi Ric,

sorry for the trouble. We are currently having problems correctly detecting the default system viewer under certain conditions, but it should be possible to work aroud this:
Instead of using the “Open document” action, use the “Run Script” action and tell it to use the Adobe Reader executable (by default for Adobe Reader DC this should be located in "C:\Program Files (x86)\Adobe\Acrobat Reader DC\Reader\AcroRd32.exe)

As nothing in PDFCreator itself displays desktop notifications, you might have installed PDF Architect together with PDFCreator by accident (there is an additional screen which you get when you deselect PDF Architect from the list of components during the PDFCreator setup, asking if you are really sure you don’t want it, pointing out the additional features it includes). You can disable the popups from the PDF Architect options (help->options->general->notification system), or by uninstalling PDF Architect.

Best regards,

Robin


#3

Hi Robin,

The workaround works fine!

BTW, PDF Architect was not / is not installed (not listed in Programs & features). The message I kept getting was (see uploaded file)

Finding the right exe was the key. I use the full version of Adobe Acrobat.
C:\Program Files (x86)\Adobe\Acrobat 9.0\Acrobat\Acrobat.exe

I greatly appreciate your feedback.

Thanx!
Ric