Unable to convert RTF file - Word 2007 hangs


#1

Hope you can help. I’m trying to convert an RTF file to PDF in PDFCreator v3.1.2 build 10844 on a Win 10 and it opens up Word and then hangs. It doesn’t open the document at all. I’ve associated the RTF file extension with Wordpad and can open it fine in File Explorer but it still tries to open it in Word. Also does the same for word documents.

Installed PDFCreator on a Win 7 machine with no Office installed and had same settings (auto save on) and it opens the RTF file in Wordpad and converts a treat.

Can anyone help me either get the rtf to open with Wordpad in PDFCreator or sort out why Word is hanging (I’d prefer to use Wordpad if possible)

Thanks


#2

Hi,

just in case it helps, you could open the file in Wordpad with the Explorer and then print it to the virtual PDFCreator printer.
The other solution would be modifying the Windows registry in order to tell Windows to use Wordpad as default application for printing RTF files. Sadly, the settings for “default application” in Win 10 only change which application opens the file type, but not which one prints it.Why the RTF itself hangs in Word I really can’t tell. Perhaps the Microsoft Support can help with this one.

Best regards

Robin


#3

Thanks Robin. I’m wanting to create th PDF with no user interaction using the command line PRINT command. I have looked through the registry and found a couple of entries where rtf was still assigned to word but changing them didn’t make any difference. Do you know which registry entries need changing please? Thanks Andy


#4

Hi,

first check the value for the (Standard) entry in HKEY_CLASSES_ROOT.rtf
On my system it is Word.RTF.8, so the command to change would be HKEY_CLASSES_ROOT\Word.RTF.8\shell\Printto\command (change to “%ProgramFiles%\Windows NT\Accessories\WORDPAD.EXE” /pt “%1” “%2” “%3” “%4”)
Alternatively, changing the standard entry in HKEY_CLASSES_ROOT.rtf to “rtffile” instead of “Word.RTF.8” should have the same effect.
Always crate a backup of your registry before making modifications.

Best regards

Robin


#5

Hi Robin, That works a treat. Thanks for your help