29100 - Internal GhostScript Error



sorry for the late response, yes the file should help to understand what might be going on.
But if even a testpage can’t get generated, the trace log would be more helpfull.

Best regards,



Hi Robin,
inside the trace log the error message is “Unable to open the initial device, quitting”.
Instead on windows screen I still have “29100 - Internal GhostScript error”.
If I use the the “virtual” printer installed by PDF Architech 4 installed together PDFCreator, the final PDF is created without errors.
I sent to you all the full trace logs to give a look.
Waiting your reply.


I finally fixed the problem with PDFCreator about error "“Unable to open the initial device, quitting” and “29100 - Internal GhostScript error”.
The problem was related to an added environment variable for temporary directory probably created by an old SW to store his temporary files.
After removed it or set as default system TMP or TEMP direcoty variable as %USERPROFILE%\AppData\Local\Temp no more erros from PDFCreator to create final PDF.
Very strange that PDFCreator or GhostScript used tmpdir variable instead system variables TMP or TEMP.


We’ve hit a couple users who still receive the error – even after applying the registry fix.

I have a debug log from one of the users that shows “Ghostscript execution failed: Scanning C:\Windows\Fonts for fonts… 573 files, 381 scanned, 361 new fonts.”

How do I submit the full log for review?



You can send the log file to support (at) pdfforge.org.

Best regards



I’m trying to send spool file to the PDFCreator printer, But same ghostscript error. Does PDFCreator print any job with spool file? I just need to generate text file while any job printing on default printer.

Thanks and regards,




I’m not sure if I get what you want to do, but generally PDFCreator should print anything for which windows says it knows how to print it. As spool files it can only handle pdf or postscript as those are the formats ghostscript can natively work with.
The ghostscript error is most likely related to the FastWebView option. This can be disabled in the registry via “HKEY_CURRENT_USER\SOFTWARE\pdfforge\PDFCreator\Settings\ConversionProfiles\PROFILENUMBER\PdfSettings” by setting “FastWebView” to “False”. PROFILENUMBER is the number of the profile you are using.

Best regards


TL;DR: Use Ghostscript 9.16 instead of the bundled 9.19 that comes with PDFcreator 2.4.1.

Hey guys.

I updated every computer in my organization to PDFcreator 2.4.1 a few weeks back. Since then, I got a few random reports about it misbehaving when trying to merge certain PDF documents. There is no pattern that I noticed... On one occasion there was a PDF with Chinese characters. So maybe it's a font issue? But it happened to documents using only regular / latin script as well. This is the error after hitting save on the merge:

and after hitting close, this:

So looking for a solution, I reached this thread.
I tried everything here, but to no avail. I enabled the Debug logging, trying to figure something out... nothing.
This is at the end of the log file:

2017-02-03 15:05:00.4746 [Debug] pdfforge.PDFCreator.Conversion.Ghostscript.GhostScript.RaiseOutputEvent: GPL Ghostscript 9.19 (2016-03-23) 
2017-02-03 15:05:00.4746 [Debug] pdfforge.PDFCreator.Conversion.Ghostscript.GhostScript.RaiseOutputEvent: Copyright (C) 2016 Artifex Software, Inc.  All rights reserved. 
2017-02-03 15:05:00.4836 [Debug] pdfforge.PDFCreator.Conversion.Ghostscript.GhostScript.RaiseOutputEvent: This software comes with NO WARRANTY: see the file PUBLIC for details. 
2017-02-03 15:05:00.6466 [Debug] pdfforge.PDFCreator.Conversion.Ghostscript.GhostScript.RaiseOutputEvent: Loading NimbusMono-Regular font from %rom%Resource/Font/NimbusMono-Regular... 4207936 2787666 1801436 516207 1 done. 
2017-02-03 15:05:00.8476 [Debug] pdfforge.PDFCreator.Conversion.Ghostscript.GhostScript.RaiseOutputEvent: Scanning C:\Windows\Fonts for fonts... 734 files, 507 scanned, 483 new fonts. 
2017-02-03 15:05:00.8476 [Debug] pdfforge.PDFCreator.Conversion.Ghostscript.GhostScript.RaiseOutputEvent: Querying operating system for font files... 
2017-02-03 15:05:00.8856 [Debug] pdfforge.PDFCreator.Conversion.Ghostscript.GhostScript.RaiseOutputEvent: %%[ ProductName: GPL Ghostscript ] 
2017-02-03 15:05:00.8856 [Debug] pdfforge.PDFCreator.Conversion.Ghostscript.GhostScript.RaiseOutputEvent: %% 
2017-02-03 15:05:01.4726 [Debug] pdfforge.PDFCreator.Conversion.Ghostscript.GhostScript.RaiseOutputEvent: %%[Page: 1] 
2017-02-03 15:05:01.4806 [Debug] pdfforge.PDFCreator.Conversion.Ghostscript.GhostScript.RaiseOutputEvent: %% 
2017-02-03 15:05:01.4806 [Debug] pdfforge.PDFCreator.Conversion.Ghostscript.GhostScript.RaiseOutputEvent: %%[LastPage] 
2017-02-03 15:05:01.4806 [Debug] pdfforge.PDFCreator.Conversion.Ghostscript.GhostScript.RaiseOutputEvent: %% 
2017-02-03 15:05:01.5896 [Debug] pdfforge.PDFCreator.Conversion.Ghostscript.GhostScript.RaiseOutputEvent: %%[ ProductName: GPL Ghostscript ] 
2017-02-03 15:05:01.5896 [Debug] pdfforge.PDFCreator.Conversion.Ghostscript.GhostScript.RaiseOutputEvent: %% 
2017-02-03 15:05:02.0606 [Debug] pdfforge.PDFCreator.Conversion.Ghostscript.GhostScript.RaiseOutputEvent: %%[Page: 1] 
2017-02-03 15:05:02.0606 [Debug] pdfforge.PDFCreator.Conversion.Ghostscript.GhostScript.RaiseOutputEvent: %% 
2017-02-03 15:05:02.0606 [Debug] pdfforge.PDFCreator.Conversion.Ghostscript.GhostScript.RaiseOutputEvent: %%[LastPage] 
2017-02-03 15:05:02.0726 [Debug] pdfforge.PDFCreator.Conversion.Ghostscript.GhostScript.RaiseOutputEvent: %% 
2017-02-03 15:05:20.0536 [Error] pdfforge.PDFCreator.Conversion.Ghostscript.Conversion.GhostscriptConverter.DoConversion: Ghostscript execution failed: Scanning C:\Windows\Fonts for fonts... 734 files, 507 scanned, 483 new fonts.
Querying operating system for font files...

2017-02-03 15:05:20.0576 [Error] pdfforge.PDFCreator.Conversion.Ghostscript.Conversion.GhostscriptConverter.DoConversion: There was a Ghostscript error while converting the Job C:\Users\i.dita\AppData\Local\Temp\PDFCreator\Spool\52-61FA7795F6EA4702B9B684380A480A5D.inf: pdfforge.PDFCreator.Conversion.Jobs.ProcessingException: Ghostscript execution failed: Scanning C:\Windows\Fonts for fonts... 734 files, 507 scanned, 483 new fonts.
Querying operating system for font files...

   at pdfforge.PDFCreator.Conversion.Ghostscript.Conversion.GhostscriptConverter.DoConversion(Job job) 
2017-02-03 15:05:20.0576 [Error] pdfforge.PDFCreator.Core.Workflow.JobRunner.RunJob: The job failed: Ghostscript execution failed: Scanning C:\Windows\Fonts for fonts... 734 files, 507 scanned, 483 new fonts.
Querying operating system for font files...

2017-02-03 15:05:20.0736 [Error] pdfforge.PDFCreator.Core.Workflow.ConversionWorkflow.RunWorkflow: Error Conversion_GhostscriptError: Ghostscript execution failed: Scanning C:\Windows\Fonts for fonts... 734 files, 507 scanned, 483 new fonts.
Querying operating system for font files...

2017-02-03 15:05:30.0616 [Error] pdfforge.PDFCreator.Core.Workflow.JobInfoQueueManager.ProcessJob: The job 'A 960 820 1281 - ZGS 007 - 9051 - GF15037366' terminated at step Error and did not end successfully. 
2017-02-03 15:05:30.0616 [Debug] pdfforge.PDFCreator.Core.Startup.AppStarts.MaybePipedApplicationStarter.Shutdown: All synchronized threads have ended 
2017-02-03 15:05:30.0746 [Debug] pdfforge.PDFCreator.Core.Communication.PipeServerManager.PrepareShutdown: Preparing PipeServer for ShutDown 
2017-02-03 15:05:30.0746 [Debug] pdfforge.PDFCreator.Utilities.Threading.ThreadManager.Shutdown: Shutting down the application 
2017-02-03 15:05:30.0746 [Debug] pdfforge.PDFCreator.Utilities.Threading.ThreadManager.Shutdown: Exiting... 
2017-02-03 15:05:30.0886 [Debug] pdfforge.PDFCreator.UI.ViewModels.SettingsLoader.SaveSettingsInRegistry: Saving settings 
2017-02-03 15:05:30.2366 [Debug] pdfforge.PDFCreator.Core.Communication.PipeServerManager.Shutdown: Stopping pipe server 
2017-02-03 15:05:30.2466 [Debug] pdfforge.PDFCreator.Editions.EditionBase.ProgramBase.Main: Ending PDFCreator 

I downloaded the font pack from Ghostscript, unzipped the fonts somewhere where they can be "seen", still the same.

I noticed that PDFCreator 2.4.1 comes bundled with Ghostscript 9.19.
So I thought that maybe there is a problem with Ghostscript itself. Let's try to update that.
I replaced it with 9.20, but still got the same error. OK, so "downdate" it. I replaced it with 9.18, same error.

I went on the Ghostscript FTP for old packaged and downloaded all available packages (back to 8.71).
I started with 8.71, and to my surprise, it worked. PDFcreator was still 2.4.1. I went through all packaged and latest one that worked was 9.16. (I wished I started from the end :slight_smile:).

I compared the 2 versions with windiff and tried to figure out what's different, but the only thing I found different in the lib folder is the ghostpdf.ini (they switched to ghostpdf.cat instead of oemprint.cat).
So the problem could be somewhere "inside" gswin32c.exe. But that is beyond me...

I use DSM to deploy apps in my company, so I just added 2 lines after the setup process copying Ghostscript 9.16 (and overwriting 9.19) and voila. problem solved.

Good luck everybody.

PS: I created an account just to post this. Hopefully it will help others as well.
PS: I do apologize for my English. I hope you understand something from what I've written.



thanks a lot for the feedback, it is caused by using FastWebView=true in Ghostscript >9.16, this seems to crash for some input files. For the next PDFCreator update, we will set this to false which solves the problem.
You can also solve it by editing the registry as mentioned above, downgrading to GS 9.16 isn’t recommended unless you need the FastWebView (linearisation) of PDFs to be enabled.

Best regards,



I did edit the registry, but it didn’t change anything…



did you edit the correct profile while PDFCreator wasn’t running?

Best regards,



I believe I did. I edited all profiles for all users on the machine…



to ensure the change is getting picked up properly, please set the logging level to “trace” in the debug section of the PDFCreator application settings and print a test page, then send us the log or check if “FastWebView=false” is listed in the parameters used to call Ghostscript. So far, disabling the FastWebView fixed this issue in all known cases so we’d like to be 100% sure the setting is getting picked up by PDFCreator before starting additional investigations.

Best regards,



I have set the logging level to trace but i can't find the entry fastwebview.
(Reg was modified HKEY_CURRENT_USER\SOFTWARE\pdfforge\PDFCreator\Settings\ConversionProfiles\0\PdfSettings)



If FastWebView is not set, GhostScript doesn’t use it.
Do you still get this error?

Best regards


So with the new PDFCreator 2.5.1, the registry entry FastWebView no longers exists or is not needed?



it is now disabled by default to prevent “random” crashes, so there is no need anymore to set it in the registry.

Best regards,



Hi Robin…suddenly I am encountering this problem, can you help me since I am regular user of this app.



which version of PDFCreator are you using? We released PDFCreator 2.5.1 a few days ago and we eliminated the most common cause for this error by always disabling FastWebView. If possible please update your installation to version 2.5.1.
If it is not possible, please refer to this post: 29100 - Internal GhostScript Error

Best regards


Got the ghostscript error and lost the “convert by PDFForge” function in Windows Explorer when I upgraded to version 2.5 and/or 2.5.1 from Version 2.4 which worked perfectly; this occured when I tried to save a protected file (created with Version 2.4) without the password, although this worked well with version 2.4.
Now I have the error even with version 2.4 re-installed after complete de-installation of version 2.5.
So it’s impossible to remove a password from a file I created myself.
Thanks for some help.