3.2.0 Drag and drop working?


Is drag and drop working for you ?
I can’t drop a file in the dedicated area and when I click on the button to select a file, I can only select one file.
I want to merge various file and I can’t …

Thank you for your help.

Hey @jeromeF,

What type of file are you trying to merge? I just tried with two .docx files (word 2016 documents) and it is working just fine with 3.2.0.

Can you elaborate or give more info? Like what happens when you drag and drop the files into pdfcreator? Nothing? Error?


Thanks for your answer.
I'm with 3.2.0 and Windows 10.
No matter the file, I have the same things :sob:

Short of uninstalling and reinstalling pdfcreator I am not sure what you could do. Weird problem that I can’t reproduce.
Sorry, you may have to wait for someone from pdfforge to help you.

I have been using pdfcreator a lot recently so if I discover something I will be sure to let you know.

Even with a clean install on a clean machine I have the issue.
Maybe it is our workstation, I don’t know…
Thanks for your help.


we have been encountering issues with reading the required “print to” commands from the Windows registry.
When you drag&drop a file onto PDFCreator, it will look for a command to print the file to the PDFCreator printer.
Unfortunately Microsoft has made more or less undocumented changes to where/how these commands are stored, so applications often don’t register the commands in the right place and/ or the .NET framework can’t find them properly.
You can find an example on how it works for .docx files here: PrinterName ignored in command line parameters
Sorry for the trouble, we have tried to make this more stable again multiple times, but haven’t yet found a very good solution.

Best regards


But will it be possible, fo example, to choose more than 1 file by clicking on the “Choose file to convert” button ?
For the moment, you can only choose 1 file.
Even if the drag and drop is not working, the user will be able to create one PDF document based on multiple file.

Another things, I have the same problem for every file I try to convert. Not only .docx file


the .docx was just an example, the issue can potentially affect any file type. The “Choose file to convert button”/Drag&Drop/“Convert with PDFCreator” entry in the context menu all use the same logic for getting the commands from the registry, if the button works but the drag&drop doesn’t, it must be a different issue than I originally expected.
Can you select multiple files and then right click and select “Convert with PDFCreator” from the context menu of the Windows Explorer, or is this entry missing?

Best regards


Are you by any chance running PDFCreator as admin specifically? I get the same issue if I launch PDFCreator with “run as admin”, but this isn’t required or recommended.

Users are not admins of their workstations.
I haven’t choose the option to integrate PDFCreator in the context menu of windows Explorer so I haven’t the option. If I add it, I can convert 2 files : I have 2 msg telling me if I’m ok to allow pdf creator to be the temporary printer. I should click OK twice, click Merge, Merge All and finally I can merge the 2 files :frowning:
I have users who want to merge more than 40 files …

It seems to be a general Windows issue (https://windowsreport.com/cant-drag-and-drop-windows-10/) and not a PDFCreator bug, does drag&drop work for other applications?

I think I have found. We use an application to manage admin right on the workstation.
When I have deleted it, drag and drop has started to work …
I have thinked about that when you have started to talk about admin rights.
That’s not a good news for me if the problem is this app :frowning:


a work around might be to use the context menu entry “convert file with PDFCreator” instead of the drag&drop workflow, this shouldn’t be affected by UAC/admin rights. Does the app always launch PDFCreator with admin rights? If it is possible to configure, please set it to not launch PDFCreator as admin. PDFCreator only needs admin rights if a user wants to create a new (virtual) printer or change the setting for the Windows Explorer integration.

Best regards


I have found a solution. We have added an exception for PDFCreator and I think it's OK now.
Thank you !