Bad characters

I am using PDFCreator with satisfaction for some time. From version 1.2.1 and up to the last 1.2.3 (just installed) some characters are rendered incorrectly. To check the situation you can try to convert in PDF the page "blog" in this site from SeaMonkey 2.3.3 or Firefox 6.0.2.

With each new version I hoped in the solution of the situation. But in vain.

How you can solve the problem?

Meanwhile I have to use version 1.2.0

Hello all,

I've been using PDFcreator version 0.9.6 for a long time, and i'm a very satisfied user.

But since the update to the latest version, i also have some trouble with the fonts printing. Is there a solution for this? None of the characters i print are visable.

I also can not find the "extended printer settings" where i can eventually change to soft fonts.

I hope there's a solution, bug fix, or just the right setting.

Please let me know! Thank you!



Here's a file to reproduce the bug:

get the file:

and print it with MS Internet Explorer. Scroll down the PDF - some "o" and "a" characters are shown as [?] characters.


[edit] Yikes! The äöü characters are shown incorrectly now in my Opera browser..

 You should try to adjust "TrueType Font..." option in "PostScript..." section of "Advanced printer options..." to "Bitmap" or "Outline". 

It worked from Opera 11.61 and Firefox/3.6.15 with PDFCreator 1.2.3


I have been using pdfcreator successfully up till version 0.9.9. All versions after that does not render fonts eg. Helmet (from Staroffice), and some narrow fonts correctly-ending up with gibberish. I hope the developers can correct this otherwise many users may need to migrate to other pdf apps.


you can try setting the font ebedding: In the extended orinter settings, you can change TrueType fonts from "replace with internal font" to "load softfont", which should fix this.



What and where are the "extended printer settings"?  Since switching to latest version of PDF Creator many characters that printed fine previously do not print at all.  These are mostly statistical characters that I have inserted as symbols in Wordperfect.  I had no problem with earlier version of PDF Creator.



Hi everybody,

when I try to print a PDF document from a web page, every now and then some characters are replaced by a blank quare.

On the german "" web site, the character "o" is replaced in the booking page. But this works perfectly on the PDFForge page, so I assume it might have something to do with the font type.

Any ideas on how to get rid of this error?

And I also could not find the above suggested setting.


I've tested the pscript5.dll change suggestion and can confirm that it works.
So BIG THANKS from my side.

For those less technical:

Extract the content of the file (using wirar for example)
Locate, use winrar again to extract pscript5.dll

Go to:

locate pscript5.dll and rename the file to pscript5.dll.bak
Copy the extracted pscript5.dll in the same location and reboot your computer.


this works for 32bit operating systems

Except that the x64 cab file is (its the biggest file of the driver package)

I also can confirm that the suggestion works.

Download the "HP Universal Print Driver for Windows PostScript".

Download 32-bit:
Download 64-bit:

Extract the file like "SelfMan" described above.

The locations of the "pscript5.dll" are:

32-bit: C:\\Windows\\System32\\spool\\drivers\\W32X86\\3\\
64-bit: C:\\Windows\\System32\\spool\\drivers\\x64\\3\\

Rename, copy and reboot like "SelfMan" described above.

I have tried replacing the dll as described above and also settings in the advanced printer preferences and I can't get anything to work.   All fonts that are smaller than 8 turn into black squares.  I am using version 1.3.1

try it with version 1.2.3 and let us know

Version 1.2.3 wouldn't install a printer I rolled back to 1.2.0 and that one works fine.  So will this bug be fixed in a new version?

You have to uninstall, reboot and then install the 1.2.3.
Don't ask me for fixes, I am only a user, not a developer.