Bug on Command Line. /NoStart option doesn't processes /OptionFile option

Hi!

We’re trying to do an automatic PDF printing from a RTF file and we’re using the command line options of PDFCreator with the OptionFile ini for autosaving.

We tried to use something like this:
pdfcreator.exe /OptionsFile"/testing.ini" /PF"\test.rtf" /NOStart

On the ini we have this (these are the important keys, the ini is extracted with save as from PDFCreator):
AutosaveDirectory=<path_to_where_we_want_the_resulting_PDF_file>
UseAutosave=1
UseAutosaveDirectory=1

If we use the /NoStart option the PDFCreator doesn’t reads the ini file and the autosaving option it’s not fired. If we remove the /NoStart option all works perfectly but we need to close the PDFCreator.exe manually or Killing the task from our application.

We saw this bug on this forum from a lot of years. So please, answer us if this will be fixed or it’s Working As Designed from something else.

Best regards and a lot of thanks for this good application.

I confirm the bug and request a solution. I appreciate that a lot of work goes into the program, just wish for this to be solved.

Hi,

Since version 0.9.9 the old ini mode is not supported anymore.
http://www.pdfforge.org/content/settings-pdfcreator
Basically it needs to be done with regfiles now.

regards,

Robin

Hi Robin thx for the comment but if the ini it’s not support why it’s working if we don’t use the /NoStart parameter.


If it’s deprecated it should be removed entirely.

Regards,