Bug: The 'One page per file' option does not work correctly

If you enable the One page per file option in Document properties 1 and turn on Autosave, and choose to autosave as a JPEG, there are two issues.

 1. The resulting filename does not append a page number, but instead includes what looks like the printf format specifier for a decimal number, %d.

2. Because of issue 1, if there are multiple pages, you still only get one file, representing one of the pages.

Steps to reproduce:

1. Check One page per file in Document properties 1
2. In Auto-save: check Auto-save and set the Autosave format to JPEG
3. Set Filename to img_
4. Check Use this directory for auto-save and set your output directory

5. Print something to the PDFCreator printer

Resulting file example:  img_20100630110546%d.jpg


just try to uncheck "Allow special Ghostscript chars in filename" in Program\\Save

It solved the problem for me without the Auto-save option.

The setting change work for me (in 1.2.3), but there should be some kind of mesasge the comes up when you set it to save pages as individual files to let you know you need to be sure that is set properly.  Otherwise people just get disgusted with a piece of software that doesn't do what is says it is going to do!

(When I check a box for software to save individual pages as separate JPG files I don't want it to save a single file with %d tacked onto the end of it!  Of course, maybe some other people would really like that function. . . .  NOT!)