Can not erase version and after c/p I get wrong ghostscript folder


I have two Windows servers with 2016 for future RDS services.

I tried to install pdf creator 1.7.1 (it's what we need here, unfortunately) and it worked on one server, but not on the other.

I get the version was here before, and he cannot find and erase it (i never installed it so it's normal if he don't find it!).

And the next message is "Runtime error : An attempt was made to expand the "app" constant before it was initialized".

After a ccleaner attemps and after a research on the regedit and so on, i decided to copy the entire program from the other server, where the program is good.

So I copy "C:\Program Files (x86)\PDFCreator" to my other server and I launch the programm.

And now, I have the Ghostscript error.
How can I change the folder of this Ghostscript? How can I force him to found the dll?

I check and I have everything I need in this folder "C:\Program Files (x86)\PDFCreator\GS9.07\gs9.07\Bin\gsdll32.dll"

I understand he can't find it because it's not a proper installation, but I don't find in the menu "Printer - Option - Ghostscript" any option to force it.

Does someone can provide me some help?
I'm lost here.
Thank you by advance.

I install the 32 bits version and it worked