Can't create PDF/A Files which are verified by VeraPDF

Hey guys,

I am trying to get a verified PDF/A through PDFCreator but no matter what I tried I can't seems to get it to work. Tried on two different machines /w Win 7 x64.

This is the message from the VeraPDF Report:

Validation information
Rule Status
Specification: ISO 19005-1:2005, Clause: 6.7.3, Test number: 1
If a document information dictionary does appear at a document, then all of its entries that have analogous properties in predefined XMP schemas, shall also be embedded in the file in XMP form with equivalent values. Failed
1 occurrences Show

I am really clueless as to what I should try next.
Thanks in advance

If I select PDF/A 2B following Error occurs:

Rule Status
Specification: ISO 19005-2:2011, Clause:, Test number: 4
If the FontDescriptor dictionary of an embedded CID font contains a CIDSet stream, then it shall identify all CIDs which are present in the font program, regardless of whether a CID in the font is referenced or used by the PDF or not. Failed
3 occurrences Show