Can't install PDFCreator


Can’t install PDF Creator! Keep getting the error message PrinterHelper has stopped working when trying to install.

As suggested I logged in as a local administrator, but still ran into the same problems.

Have tried to follow some of the suggestions on the forum but they haven’t got me anywhere.

Please can someone help me with this?



the setup itself should be able to complete itself, even if the printerhelper.exe crashes in the middle of it.
Is this the case on your machine, do you have a PDFCreator folder and desktop shortcut (but every time you launch PDFCreator, you get a message about the broken or missing printer)? Once we know the current status we should be able to help you with this.

Best regards




Yes Robin. It has been able to install on my machine and I have a folder indexed C:\Program Files\PDFCreator

And yes when I try to open it I get the message that No Printers Installed.



pdfcreator no printer installed


Hi Nikki,

ok great, then we can get started troubleshooting the issue. First please run cmd.exe as administrator and navigate to the PDFCreator folder (by entering cd “C:\program files\PDFCreator”).
Now, run printerhelper.exe /uninstallprinter
Does this work, or does it already create error messages?
If it worked without errors, you can now run printerhelper.exe /installprinter PDFCreator /portapplication “C:\program files\PDFCreator\PDFCreator.exe” which will either install the printer correctly or give an error message containing additional information on the issue.
If you need assistance with any of this just let us know and we will be happy to help.

Best regards



Hi Robin

This is as far as it got.

Thanks Nikki

pdf error


What do I do now? I’ve only been able to get as far as the image.




Hi Nikki,

there is a blank missing in your call (program files), please correct this and try again.

Best regards,



I have the same problem.
I performed the same procedure, but the problem has not been solved.
In the command line you can see the error twice.
the second error occurred after I manually tried to insert a local port: "pdfcmon"


I tried to uninstall and reinstall everything;
I tried to stop the spooling service and delete all the contents of the directory
system32 \ spool
I tried to delete HKEY_LOCAL_MACHINE \ SYSTEM \ CurrentControlSet \ Control \ Print \ Monitors in the registry
as suggested in previous posts on your forum

no attempt has solved the problem



is there actually a PDFCrator.exe in C:\program files\PDFCreator\ on your machine? If you changed the path for the PDFCreator installation, you will need to change the path for the /portapplication parameter accordingly.
It should only give this error if it isn’t able to find the file at all.
Sorry for the trouble.

Best regards



I have not changed the path
I uninstalled the program completely, done cleaning and tried to reinstall
following the instructions provided in the forum posts
but it does not work


I’m having this exact same problem. I’ve followed the steps here and in another post about the issue and nothing is working. Is there a solution for this problem?


Hi all

I was the same installation was in the correct path but none of this worked! So frustrating!

Anyway I managed to solve the problem! It was just the security settings (virus software) on the computer that prevented the computer from installing the print driver. I had to disable certain drives in the virus software in order to be able to install the driver correctly.


Could you explain what you did to fix the problem?



did you run all the printerhelper commands manually as indicated above? If yes, did you get an error message?
It sounds like in some cases anti virus software might be “protecting” the driver files from being deleted/replaced, in which case temporarily disabling your anti-virus during the setup should solve the problem. Sometimes only the automatic removal is prevented and you can still delete the driver file manually.

Best regards



I have run the commands just like they are shown above. I got the same exact results. I will try disabling the anti-virus software and see if that solves the problem.



just to be sure, you got the error “no port application specified” with /portapplication pointing to an existing PDFCreator.exe?

Best regards




I tried to run the commands through cmd.exe with admin privileges again just to get a screenshot of the error i'm getting. It is not the same, my apologies. Here's a screenshot of the error i'm getting.

When trying to install PDFCreator I usually get to the part where it starts to install the printer and get the "PrinterHelper has stopped working" pop up.



thank you for the screenshot.
It shows the root of the issue is being unable to delete/replace the file C:\windows\system32\spool\drivers\x64\PSCRIPT5.dll.
Please try to rename this file with the Windows Explorer, if it works please run PDFCreator again after renaming the file and there is a good chance it will be able to fix/install the printer. If renaming doesn’t work, please enter the command “net stop spooler” into cmd as admin and try again (this will halt the printing system).

Best regards




I uninstalled PDF creator, then renamed C:\windows\system32\spool\drivers\x64\PSCRIPT5.dll to PSCRIPT5.dll.old, tried to reinstall ran into the same problem. Did the Net stop spooler command from CMD as an admin, found 2 copies of C:\windows\system32\spool\drivers\x64\PSCRIPT5.dll including the .old one, deleted both of them. Uninstalled Pdf creator and then reinstalled again following those instructions again.

Another copy of Pscripts.dll was placed back in the folder and I ran into the same problem, at the same point during install.

Any other suggestions?



I tried the install again and still got the same error. I opened the 'setup log' and it shows a different error code, didn't know if that would be helpful. I'll paste it here.