COM interface broken

 This is very possibly my own fault, but any clarification of what I did would be great.

I am using the COM interface in two separate applications, and have been since 0.9.6. I made some changes in December using 1.0.2, compiled, and everything was brilliant.

When I got back from holiday, I had to make a minor change, and in a rare moment of good practice, I first tested the existing binary to remind myself how everything works. It froze my computer for about 30 seconds, and then exited without printing.

I updated to 1.1.0, then compiled and ran the VB6 Sample1. This gave a run time error 7 (out of memory), and when I closed the exe, error 462 (remote server machine does not exist or access denied).

I then opened the PDF print monitor, the Sample1 job was there, and immediately printed without any prompting from me. It had however lost everything from cOptions, so asked for a filename etc.

Unlike Sample1, my app only waits for the eReady or eError events for 60x250ms=15s, and then, well frankly doesn't do anything useful, whereas Sample1 continues looping until it gets the out of memory error. If you watch the memory use in task manager it's pretty clear it's gonna end badly.

I compiled my app, and copied it onto another XP machine, after installing 1.1.0 there too. This worked without any problems, so feeling brave, I tried it on a windows 7 box, where the out of memory thing happened again.

Any suggestions?