Dcom pdfcreator.clspdfcreator not found

Hi all,
i am trying to access PDFcreator print through automation from .net application. i am getting error as

--Unable to create an instance of Automation Server PDFCreator.clsPDFCreator with CLSID = 40108c54-9352-46c9-822c-027727352f00 Retrieving the COM class factory for component with CLSID {40108C54-9352-46C9-822C-027727352F00} failed due to the following error: 80070005

In event Viewer error -

The machine-default permission settings do not grant Local Activation permission for the COM Server application with CLSID




to the user NT AUTHORITY\ETWORK SERVICE SID (S-1-5-20) from address LocalHost (Using LRPC). This security permission can be modified using the Component Services administrative tool.


i tried all other users have mentioned.  But iam not able to find pdfcreator.clspdfcreator  in dcom config its missing.

please some help on this as well as he error... i am stuck in this error for 3 days



thank you



I have not worked with DCOM before, so I am probably not of much help there. But I can tell you that the COM class is registered and located in the PDFCreator.exe, maybe that helps to get you on the track.

kind regards,