Error 484 - default printer issue

I am new to PDFCreator and have a question.

I have an application which controls printing of documents from an application in our environment.  This application sets the default printer as part of it's process prior to printing each document - this default printer path is taken from a file of user/printer associations.

If the request for print is type EMAIL, we call PDFCreator via the command line as part of the application, then attach the resulting PDF doc to an email and send via SMTP.

When first testing this all worked OK, until we then sent a regular PRINT in amongst the email requests. 

This is what happens:

1. Send an email request, PDFCreator is called, switches defualt printers to the PDFCreator printer, converts the doc, then switches back - OK  We can do this as many times as we like - all works fine.

2. Send a PRINT request, the application sets the default printer to the users associated prnter, prints the doc and completes OK.

3. If we then send another email request, the document is created, PFCreator is called but fails immediately with the 484 error - Problem getting printer information.

If we manually set the default printer to one other than PDFCreator all works and PDFCreator switches temporarily.  It seems to only cause an issue when the application sets the default printer.

We have amneded the APP to set the default printer to the PDFCreator after each print, but we still get the same error 484.  I think this is tied to another post I saw whereby they point to the code in line 50060 of module ModMain - where it checks for the default printer.

I can see the source code, but am not 'savvy' enough to know how to amend this and create a new exe from it.  What I want to do is to have PDFCreator not check for the default printer - as I know it will be set to PDFCreator every time by my application.  I guess this would involve commenting out the code around this line 50060 of ModMain.  When I get the error if I press Next Command it stops at line 50200, and if I press Next Command again it completes and converts the doc - but leaves the PDFCreator task running in the background.


Any help appreciated.



Can anyone help me with this ??