Error connection to server


When I try to activate my copy of pdf architect (Create module - free registration) i receive an “error connection to server”.



there are several users who worte that, we are looking into that and will let you know when we find the reason for this.

kind regards,


please try it again now, the problem should be solved now.

kind regards,

I just upgraded my PDF Creator and discovered the Architect. Seem to be a piece of helpful software, but hey - I can’t activate the “Create” module. The pop-up message reads: “Error connection to server”. Looks like the problem is still here.


I’m having the same problem.



I am also receiving the same message


it should work again since yesterday. I will try it myself in a few minutes.

@SeaRat: Do you have some kind of corporate firewall or similar running that could cause this?

Hi Philip,

We use a proxy server. I ave connected my machine directly to the internet, and the Activation worked fine.

Thank you

i have no firewall or proxy and I get a cannot connect to activation server as well.


we can´t see a problem with the server from our side at the moment, could you kindly try again to ensure it was not a temporary problem?



Am experiencing the same error also, my connection is ok but cant activate the product.


Yes this works perfectly fine on our servers running for cloud services.


is anybody still experiencing this issue?

I still get the error box every time I try to register. I tried reinstalling it, but still no success.

Are you behind a proxy and have you checked your firewall settings?

No proxy and I have tried it with the firewall disabled.
The only unusual thing is that I am using a wireless modem, an O2 dongle, but that usually works O.K.

I have the same problem. I also tried unsuccessfully with the firewall disabled.

Still a Problem: “Error connection to server.”

I have made a new download and installation of PDF Architect and now it works …

I have the same problem “Error connection to server”. I have already reinstalled PDF Architect but still it is not working.