Error Message 339

Hi there,

everytime i start to print a document with pdfcreator i get this message!

i downloaded and installed the component 'MSCOMCT2.OCX' alredy but it didnt worked (

i also gave the user all right for 'MSCOMCT2.OCX' without success (i dont work with the administrator @ work)

my system:

windows xp SP3

hope u can help me

thx brNwsH

(sry 4 my bad english, i also postet it in the german area but nobody replied i need the answer fast)

I have the same problem,

using Windows 7 Build 7100.

I get exactly the same error, tried compatability mode no joy. BUT... I Exited prog using Button on Bottom right then opened PDFCreator via the desktop shortcut and the document was there waiting to be saved.


hope this helps until it gets sorted :)





Hi Whitey

nope it doesnt help cause when i open pdfcreator with the desktop shortcut it shows me the same error and i cant quit the prodecure it pops out everytime as u can see on the picture

i also checked the access to the folders with filemon

i gave the user all right for c:\\windows and c:\\....\\PDFCreator\\ without success

some1 any ideas?


thx brN


I've got the same problem. When I try to print with the virtual pdf creator printer appears the same error that brNwsH explained (code 339). No one has the same problem? I've got this alert message using Windows Vista SP.1 and printing from Autocad 2009 LT.

If someone have a little suggestion... :)

I must also ask sorry for my english but I'm italian.

 After downloading you must register this file with

regsvr32 MSCOMCT2.OCX



Do you mean "Start" - "Run" - "regsvr32 mscomct2.ocx"?

Thanks for your fast answer :)

i tried to register already but i didnt worked!!

i found another programm which works as an virtual printer too.


1. You need to download and install ghostscript ( its something like the basic codes for the programm like .net or something

2. You donwload the programm ( the page is in german i dont know if you unterstand it so i put an image. it shows where u can download the latest version (

3. after installation open an word document go to print and select FreePDF!

thats it! have fun!





Edit*: sry i dont know if i can put link to other programms but in this case i hope u can make an exception

You should me more specific.

I have the same problem. I'm on Vista.

Ca you please explain us where to put "MSCOMCT2.OCX" on the computer ?

If you just put it on your desktop afetr downloading (that's what I did) I ran the command line to reg the ocx file, had the confirmation it was registered, put I still get this 339 error.

Please help !!!!

I had the same problem on WinXP SP3 but it is now solved. What I did was unresgister MSCOMCT2.OCX and then reister it again. Just registering it as Frank sugested was not enough.

    regsvr32 /u \\windows\\system32\\MSCOMCT2.OCX
    regsvr32 \\windows\\system32\\MSCOMCT2.OCX

This solution was posted in 2007-12-21 02:11:52 by Andreas Greve, for a previous version of PDF Creator.


This solution does not seem to work for me.  I have unregistered and re-registered the MSCOMCT2.OCX file several times plus uninstalled/reinstalled PDF Creator several times and I continue to get this error.


I have used this software on countless machines, and this is the first time I am getting the error.  I am really in a bind, because I need both pdf printing AND the combine functions, and this is the only software I have found that does it so easily.


Any suggestions?


I just had the same problem and solved it this way (Windows XP SP3): Locate the file on your system partition. Click for example on C:\\Windows and search for it there. It should be e.g. in C:\\Windows\\system32. Right click on the file and select "Properties". If you don't see a security tab, your user has no read rights for the file (for whatever reason that might be...).

Log in with an administrator account and find the file again. Right click, properties, and this time you should see the security tab. Click on "Add" and add the normal user group (sorry, did this in German where it is "Benutzer", try typing "user" and then the button next to the field and it should come up with the correct name). Add this group and check the boxes next to "read" and "read, execute". Don't give it write rights. Click "Ok" and change back to your normal account. It should work now.

By the way, before I got this error I couldn't even start PDF Creator. To get rid of the "failed to initalize properly (0xc0000022)" warning, I had to do the same for MSVBVM60.dll.

 well, my problem its a lil bit different from the one you have brNwsH, however have sum similarities, i get the error in the installation for MSVBVM60.DLL also a file associated to PDFCreator, got to say that none of the above solution worked for me that why i signed to post my way to solve. 

I figure that its posible to solve yours as well as i do. So wut i did was to type regedit in "run", then in the register look for "find" command and start searching for the filename in my case it was MSVBVM60 without the extension (.dll) and changed the name for every file i encountered for any name u would remember like "MSVBVM60-test" in case of any further problems, however i didnt have none. So after that, installed the software once again and the error was gone, it worked beautifully. 

Best regards hope it works for someone.

All these OCX files turned out to not be my problem at all.  I'm hoping the PDFCreator people can figure this one out, but here's how I fixed the problem:  I ran the application that I want to print with as "administrator."  I have PDF Creator installed on at least a half dozen Windows 7 64-bit machines, and ONLY the one that has my art software installed on it (what I affectionately refer to as my "studio" computer) can't print to PDF's without firing off the error (339, some gobbledegook about not registering properly with a VB6 runtime file called MSCOMCTL.OCX).  I can't even run the PDFCreator control program from the start menu without the same error coming up!  The fix?  Right-click on the program you want to print to PDF with, and run as administrator.  Don't ask me why, but that fixed the problem.


Any thoughts??

Hi i found a solution for my windows 7 64bits at

I hope it helps

Another solutions is download MSCOMCTL.OCX at The file should be placed in your C:\\WINDOWS\\SYSTEM directory.

After that go to Start > Programs > Accessories > RIGHT CLICK ON "Command Prompt" and choose "RUN AS ADMINISTRATOR".

Then type cdC:\\Windows\\System The prompt should change to: C:\\Windows\\System.

Then type regsvr32mscomctl.ocx

If you get a Window that pops up and says, "DllRegisterServer in mscomctl.ocx succeeded" then click OK and try the frontend install again.





Sorry for my bad english, but today i found a solution, the user must be administrator.