Error signing 12999

I was already signing documents in PDF Creator, but since I've updated to 4.0.3 version, I get error:

An error occurred: Error signing the document (12999)

[Error] pdfforge.PDFCreator.Core.Workflow.ConversionWorkflow.RunWorkflow: Error Signature_GenericError: iText.Kernel.PdfException while signing:
Unknown PdfException.
[Error] pdfforge.PDFCreator.Core.Workflow.JobRunner+d__10.MoveNext: The job failed: iText.Kernel.PdfException while signing:
Unknown PdfException. (Signature_GenericError)

Please let me know what to do.

Error PDF Creator



I have exactly the same error.

I'm on 4.0.3. Trying sign documents using profile, and also trying using COM interface with same result.

I tried downgrade to version 3.3.0 - but signing using COM gets the same error - 12999.

Looks like you need to import the certificate into windows. Then it works again.

Problem is back again. Same with versions 4.0.3 and 4.0.4
It doesn't depend on whether I use com interface or direct printing. Certificate didn't change. But I also tried old certificate with same result.

Yeah, i have the same error again. I tried to version 4.0.2 but gets the same error.