File permissions using auto-save on Windows 7 Pro SP1 x64

A few days ago I installed PDFCreator 1.7.0 in Server mode on a fresh Windows 7 SP1 64-bit system. I configured it to use autosave on a Windows 2008 server and it points to \\fileserver\users\L\PDF-Printer\. Test prints with the Monitor running worked fine. I did a few system reboots just to verify and all jobs worked fine.

I then configured PDFCreator to run as a service using the instruction on The service is using an account that has access to appropriate directories and is used by a few copiers for scan to file functionality. Again, a few reboots and several tests by 4 users work fine.

Today users complain the printer is not working. When I look at my directory or theirs I do not see the PDF files. If I view the same folder from the PDFCreator machine I do see the files. FYI, I am logged into the Win7 machine with a different account than the service account. When I check properties of the PDF file the security tab displays a red X with the text “The requested security information is either unavailable or can’t be displayed”.

I’ve stopped/started the service, tried using monitor with the service on and off, still no luck.

Any ideas would be greatly appreciated.

5/1/2013 9:39:27 AM: Autosavemodus: 1files
5/1/2013 9:39:27 AM: Autosavemodus: Create File '\\FileServer\Users\username\PDF-Printer\Test Page.pdf’
5/1/2013 9:39:27 AM: Ghostscriptparameter:
-IC:\Program Files (x86)\PDFCreator\GS9.07\gs9.07\Lib\
-sOutputFile=\\FS1\Users\dbenton\PDF-Printer\Test Page.pdf
5/1/2013 9:39:27 AM: Time for converting [PDF without encryption]: 00:00:00:262
5/1/2013 9:39:27 AM: Autosavemodus: Create File ‘\\FileServer\Users\username\PDF-Printer\Test Page.pdf’ success

BTW: I also added the service account to the PDFCreator machine’s local Administrators; hoping that alleviates any security issues.

Found the problem… a GPO was set to enable offline cache mode. For whatever reason, PDFCreator thought the User folders were offline so the file was in cache but not on the server. Disabled caching and changed GPO. Seems to be working fine now.