Fonts not printing correctly and ConversionWorkflow Error

Recently, after working well for a long time.

My PDF Creator has begun not printing the fonts from Revit correctly. The font themselves are not unique in anyway using only Arial Narrow. Also it remove any filled black colours and solid filled colours in general. Further to this I also get errors simply trying to print a Word Document as below. So believe it is not isolated to the one application.

I have uninstalled, cleared registry etc. reinstalled newest version to no avail.

Here is an error from the trace log if anyone could help.

2021-03-16 00:06:40.5289 [Debug] 28720-40 () pdfforge.PDFCreator.UI.Notifications.NotificationService.b__9_0: Creating thread of StartBackgroundWindow()
2021-03-16 00:06:40.5289 [Debug] 28720-41 (SingleErrorNotificationCall) pdfforge.PDFCreator.UI.Notifications.NotificationService+<>c__DisplayClass12_0.b__0: Creating thread of ShowErrorNotification()
2021-03-16 00:06:40.5289 [Error] 28720-10 (ProcessingThread) pdfforge.PDFCreator.Core.Workflow.ConversionWorkflow.RunWorkflow: FilePath_InvalidRootedPath / Invalid Profile
2021-03-16 00:06:40.5439 [Debug] 28720-10 (ProcessingThread) pdfforge.PDFCreator.Utilities.Threading.ThreadManager.StartSynchronizedThread: Adding thread
2021-03-16 00:06:40.5439 [Error] 28720-10 (ProcessingThread) pdfforge.PDFCreator.Core.Workflow.JobInfoQueueManager.ProcessJob: The job 'FILENAME REMOVEDl' terminated at step Error and did not end successfully.
2021-03-16 00:06:40.5439 [Trace] 28720-10 (ProcessingThread) pdfforge.PDFCreator.Core.Workflow.JobInfoQueueManager.ProcessJobs: Removing job from Queue
2021-03-16 00:06:40.5439 [Debug] 28720-10 (ProcessingThread) pdfforge.PDFCreator.Utilities.Threading.ThreadManager.WaitForThreads: 3 Threads remaining
2021-03-16 00:06:40.5439 [Debug] 28720-10 (ProcessingThread) pdfforge.PDFCreator.Utilities.Threading.ThreadManager.WaitForThreads: 2 Threads remaining


Hi there,

My office is experiencing the same issue as above. Starting yesterday March 17th, 2021 our PDF Creator program has begun converting Arial font to Helvetica when printing from REVIT to PDF. We Have been using the professional version of PDF Creator now for almost 2 months with no issue, so we are very curious as to why this has begun being an issue and what will be done to solve it?


Related to Windows Update patch KB5000802?
"Unexpected results when printing from some apps or to some printers.
Issues might include missing or solid color graphics, misalignment/formatting issues, or printing of blank pages/labels."

Try installing KB5001567 from Windows Update.
March 15, 2021—KB5001567 (OS Builds 19041.868 and 19042.868) Out-of-band

Hi Gianni + Jake,

@Gianni1962Pc - Thank you! I think this maybe related to a windows update causing the issue as I recently saw a company have to send out a fix for their PDF functionality as part of their app due to windows update. But I have been regularly updating my windows and seem to be up to date. I will for sure install the above link to be sure and try again.

@jtpye extremely frustrating no doubt. Maybe also try the windows patch. I have also got a ticket open with PDF Creator who are looking into my issue at the moment. will post the solution when they get back to me.


New Windows Update patch to correct some printing bug:

March 18, 2021—KB5001649 (OS Builds 19041.870 and 19042.870) Out-of-band

"Updates an issue that fails to print the graphical content in a document after installing the March 9, 2021 update."

j'ai essayé de faire cette mise a jour du catalogue de Windows update, mais le lien de téléchargement ne répond pas.

Probably you are using Chrome and for some unknown reasons you must right-click on the link and select Save link as ...

Thanks @Gianni1962Pc,

I have updated my windows with the package you recommended and also via Windows Update, but for some reason am still having the same issue. Maybe this has resolved it for some different PDF Drivers but not sure if it has worked for this.

Did anyone else have any luck using this update to resolve the issue?

Are you sure you have installed the correct package for your system?

titsamoha is one of those who has resolved the white band issue this way, you can read his response here:
Espace blanc au milieu de la page

But yours is a different issue.

pour moi le problème est resolu,j'ai installé le package suivant:
il faut choisir la mise a jour qui correspond a ton Windows.

Hi @Gianni1962Pc

I tried again today and it seems to have resolved, maybe my computer needed a restart or something, but everything seems to be working normal again. I appreciate you input and have marked your reply as the solution.

Thanks for your help! :slight_smile:

At the end of the patch installation, the patch should have specifically asked to restart the pc.
Are you sure you haven't missed it?

However, in general, I recommend restarting your pc whenever you encounter abnormal behavior and after installing updates.

This applies to:

  • pc of every brand and type
  • smartphone
  • cordless
  • printers
  • modem
  • router
  • wherever there is complex software to manage the hardware

But I recommend:

  • first close the documents and save your work
  • consider if it is one of those cases in which it is better to wait a little longer for an operation still in progress to be completed

Bonsoir titsamoha, Thank you so much for this link - the white stripe on every page of pdfs has been causing me to tear my hair out! But your link and the Microsoft update has restored my Pdf creator to normal working, well done. Issue resolved.

Good evening Paul01980 Paul01980,
no problem, but we must especially thank Gianni1962Pc it is he who gave me the resolution of the problem.