How to add 32bit printer driver?

 I have lastest version installed in server mode on windows server 2008 R2 and my 32bit clients can't download the driver only the 64bit ones. If i check the printer at sharing\\aditional drivers 32bit drivers are missing. So how to I add them ?



I have the same problem! How did you fixed it?

PDF-Creator isn't adding 32bit-Drivers during installation on a Win 2008 R2 Server (64bit)!

I'm not able to add an 32bit-Driver from an 32bit-Client, which was the way, I did it, with other printers.


Thanks for reply



 Did I asked something stupid or no one can help me?


don't you get any 32 Bit drivers or are they only missing for older Windows versions? Windows x64 does not accept kernel mode drivers anymore, as the PostScript printer for Windows 9x. So there is no way I know to install them. You should be able to store the drivers for Windows XP/7 x86.

kind regards,



sorry but your reply is not clear for me..

This is my problem:

Till today  I had the previous 1.2.3 on windows 7. I have also a virtual machine Xp 32bit which printed fine.

Now I have just installed the 1.3.2 but the share printer procedure needs x86 driver (just like the old procedure..) but they are missing. What sould I do?


thank you.





Have you tried the Serverinstallation? (Use the setup switch /Expert for the latest version.)

We have the same problem as this. Have made sure that I’m in Expert mode and specify to install the additional x86 driver on our x64 server, but it makes no difference… the 32-bit driver is still not installed.

Is there any thing we can do about this? We need to host the PDFCreator on a 64 bit server, but all our client PCs are 32-bit Windows 7.


could you please post your setuplog.txt here? 

We have not been able to reproduce this so far.



One of my customers is having the same issue.  He has Architect installed on 2003 64 bit and he shares that printer to install on an XP box to print to it and store the files on the server he gets that there are no drivers for this OS installed.  I had him go into the printer properties to install the x86 drivers and it can’t find any .inf files to install them.


this thread is about the PDFCreator,
please post it in the PDF Architect section to keep things nice and clear:)