How to embed Fonts in PDF?

I've used PDF Creator for a long time. After upgrading my computer and installing PDF Creator I am having trouble with fonts. The fonts used in the original document are not in the PDF, they have been substituted with other fonts. This happens on the computer that created the document and the fonts are definitely on that computer. It appears the correct fonts are not included in the PDF.

There used to be a setting to embed the fonts in the PDF is there anything similar in the latest version? I can't find it.

The fonts are not rendered as graphics and the same font worked in older versions of PDF Creator.

I, too, am looking for this setting.

I can confirm the same issue. In version 2.2 fonts appear in the PDF as they do in Microsoft Word. I just purchased PDF Creator Professional and tried using the latest version and the fonts are defaulting and not the same as the original document.


in general PDFCreator will still embed all fonts by default, unless they are substituted as configured in the printers properties (This mainly affects Arial getting replaced by Helvetica). The font needs to allow being embedded, too. Some applications don't output actual text but render it as vector graphics.
Could any of this be causing the issue you are describing? Please explain what went wrong as detailed as possible and we will be happy to look into it.

Best regards


Hi Robin,

I basically have vm's creating word documents in Word 2019, they are then converted to pdf using the COM interface in python. When I use pdf creator v2.2.2 the resulting pdfs are rendering fonts correctly (in this case the font is Roboto). When I use hotfolder on the latest version to test, the Roboto doesn't render correctly. If I edit the file in Adobe DC it says that it is Roboto, but the resulting rendered font is not. I am happy to send examples of the input and outputs. In the mean time until this is resolved is there any chance I can get an offline version of 2.2.2? It doesn't install anymore from the installation file I have.



Hi @Sam_Elmer,

I'm afraid we can't provide you with a link to PDFCreator 2.2.2.
Please contact the PDFCreator support via the knowledge base.