I always have to switch to professional mode

Hi,

Upon startup, PDF Architect is always in Free mode. I always have to switch to Professional mode using the "Switch product" button. How could I start in professional mode directly ?

Thanks.

Hi @Samoreen,

Thanks for reporting the issue.

Is there a way to reliably reproduce this behavior?
For example: After restarting the PC or using your license on another PC?

Hi,

Actually, it seems that the PDF Architect Pro validation doesn't "stick".

I switched to Pro yesterday and launched it multiple times since then and it opened in Pro mode each time. However, I'm using it once in a while and obviously, this is what is causing the problem. After a given period without launching PDF Architect, the Pro mode is disabled.

I've had PDF Architect Pro V5 since 2017 and now all of a sudden I don't have the Pro version anymore either. I've tried putting in my validation number again but it remains the free version. I would like to know if the Pro is disabled also.

If you find out what the secret is, please publish it. I had mine set to auto-renew and after processing my payment, they deactivated the program. For the past 3 months, I've been trying to get support to get it reactivated but have not been successful. I've even requested refund and evidently they don't know how to do that either. Meanwhile, they've wasted 3 months of my subscription as well as countless hours trying to get resolution. It worked perfectly until they renewed the subscription.

Very disappointed with customer service!!

Did you ever find a fix to this issue? Mine is doing the same thing?

No. Never got an answer from the "support". After a while, I always have to go to Help | Switch product to re-activate the Pro version.