Network Print Server - SBS 2011 - Saving as logged in User

I've read through the helpfile and surfed the forums. Everyone seems to be using either or to get a network path to work for independent users.


From what I can tell REDMON_USER was used for server 2003/xp/2000/etc but is antiquated for Server 2008R2 and newer.

I see references to using instead of , however when I use it just saves to the user account on the server no matter whose computer I'm printing the pdf document from.

-There was a post I read that mentioned using a mapped drive instead of a UNC path, unfortunately that didn't work for me.

  *I tried using H:\\ (as that drive is mapped for every user), H:\\, H:\\%Username%, H:\\, H:\\, and H:\\ without success.

-I also tried all of the above variations to the path \\\\myServer\\Profiles\\

-Modifying the registry key for "AutosaveDirectory" under HKLM -> Software -> Wow6432Node ._ PDFCreator -> Program to use the above variations wasn't successful.

-Someone mentioned a potential bug with the "Use Standard Author" under the "Document" section within options, however I tried with both use standard author selected and unselected without success.



I'm deploying PDFCreator 1.4.0 as a network PDF printer and need it to save to network paths based on usernames. The environment is SBS 2011, however the kernel is the same between 2008 R2 and SBS2011 so I'd expect the process to be the same (granted I could be way off there).


Everyone seems to indicate this is fairly easy to do, I'm just not sure what step I'm missing. Any help would be appreciated.





you can either change the options from an account with writing permissions, or edit them manually in the registry.







It looks like the saving to the user profile works after I've configured PDFCreator to run as a service and restarted the server.... not sure why changing to a service would have fixed it but that's okay since it's working :)


I do have a second issue where it's reading the registry settings on the server for the options, and there is no registry key on the local machines for it as it's a shared printer.

While it works as is, I'm not quite sure how I go about changing the options. The program itself won't work (or at least that's my understanding) because any changes I make happen as the logged in account, and I have the PDFCreator service set to run as a service account with limited permissions (that doesn't include logging into the server to make changes to the application).