No Luck running installed PDF Architect 3 on second drive

I have been a user for sometime now and had PDF Architect 3 was installed on another computer that died, but HD was fine, so purchased new PC and installed that HD as 2nd drive.

Scenario 1
I created a shortcut to run software. When I start the app I get this critical error:
Since the app is no longer on my boot drive I cannot uninstall and reinstall as recommended in a number of posts I have read.

Scenario 2
I attempted to install on boot drive using original downloaded installation file stored on 2nd drive, NO LUCK. So, I downloaded and attempted to installed from that file, again, NO LUCK. All attempts to install Produce this error:

Any help with finding a solution to either scenario would be greatly appreciated.

sorry for the trouble.
Did you download the latest installer from ?
I wasn't able to reproduce the issue running this installer.and it shouldn't do any self-update as shown in your screenshot.
A firewall blocking the installer could also potentially be the issue, please check if nothing is blocing the installer on your system.

Best regards


In my pursuit to overcome the problem, I somehow followed links that brought me to the location you have provided and last night was able to download and install successfully. The installation file was half the size of the installation file I had previously loaded but worked like a champ.

I was also able to find old emails with links and activation keys that worked as well after the install. I keep thinking I had the edit module, but could not locate any info on the upgrade. Is there any place to verify what upgrades have been purchased?


You can try the transaction finder at to locate your purchases or search your inbox for mails sent from to locate any purchased license keys. Inside PDF Architect, there is a "license information" tab inside the help section which will tell you what modules are currently activated.

Best regards