No PDF file created on Windows 7 from custom application


we are getting closer to the problem, just to rule out a possible source of error, can you check the version number of your pdfcmon.dll (should be

Connecting via RDP should work of course, just trying to gather as much information as possible for testing purposes.



having the same problem.
My Version of pdfcmon.dll is, size is 94.5 KB, date is 2012/07/29.


i just did some research on temp environmental variables using remote desktop. it appears they are now adding a subfolder using the RDP session id dynamically to the temp environmentall variable.   i’m not a server guy, but it seems this might be the culprit.  check out:

which points to a possible solution (i haven’t tried it yet) at the bottom from MS:


Hi Robin,

Yes, my pdfcmon.dll is Version


Hi Guys,

I just connected to my remote PC using TeamViewer instead of RDP.

PDFCreator worked as expected - no problems.

So the issue with PDFCreator (for me anyway) is definitely RDP.

Ray Green.

Hi Robin:

I’ve been able to try a couple of your suggestions for our problem:
re: advanced logging - the pdfcmon.log is not to be found on the drive
re: pdfcreator logging - after a couple of tries running our application with no PDF output:

28/09/2012 2:55:36 PM: PDFCreator Program End
28/09/2012 3:09:53 PM: PDFCreator Program Start
28/09/2012 3:09:53 PM: Windowsversion: Windows 7 6.1 Build 7601 (Service Pack 1) [TerminalServer IsWinXPPlus IsWinVistaPlus IsWinVistaSP1 IsWindows7]
28/09/2012 3:09:53 PM: InstalledAsServer: False
28/09/2012 3:09:53 PM: MyAppData: C:\Users\broy\AppData\Roaming
28/09/2012 3:09:53 PM: PDFCreator spool directory (Write access: true): C:\Users\broy\AppData\Local\Temp\PDFCreator\Spool\

pdfcmon.dll reports: