PDF Architect 5 Pro + OCR SLOW @ Loading, Opening PDFs and Editing PDFs

I purchased PDF Architect Pro + OCR (version 4) on 31 Dec 2016 hoping that it would work faster than NitroPDF or FoxIt and use it as a cheaper alternative to Adobe Acrobat DC (which I use @ work).

The performance of PDF Architect Pro + OCR is rather lacking in cheers and kudos, i.e., it is damned slow and either freezes or crashes at times. This is regardless of the PDF file I am opening. ?!?

Anyone else experience this?

Adobe Acrobat Reader / Adobe Acrobat Pro DC opens PDF files in an instant. In an instant, I don’t even have to count the seconds and the file is ready to be accessed or edited. Editing is not a hassle as well, easy peasy!

My recent (I’d say recent because I rarely need to edit PDFs). PDF Architect is a pain in opening a PDF, it does not take seconds… I actually have to distract myself with another activity for a minute or two for a single page PDF to be opened in the PDF Architect GUI. What is this??

Seems like it is thinking… WAY TO MUCH???

When I go into “EDIT MODE”, for example, I want to rotate some pages on the PDF, it takes 10 years (in my count) to get to that function’s UI space, then I have to be careful to do it slowly, before PDF Architect crashes.

There were times when PDF Architect would just crash… when editing. I think I was trying to HIGHLIGHT in colour certain text. It was an 8 page PDF (an invoice). After the 5th highlight, the application would freeze to death and I will have to kill the task in Windows Explorer.

This is rather quite disappointing. And then… it seems like PDF Forge (PDF Architect) wants me to upgrade to V. 5??? What?

Why would I pay extra $ to upgrade when the current version does not even work. :frowning:
This is really bad.

FYI: My Order No. U953PYQC; Purchase Date: 12/31/2016 6:26:32 PM

Please, someone get back to me before I explode. I hate seeing your Desktop Notification all the time, it’s time to UPGRADE//// BUT WHY???


:exploding_head: :face_with_symbols_over_mouth: :rage: :anguished: :weary: :-1:t3: :-1:t3: :-1:t3: :-1:t3: :-1:t3: :-1:t3: :fist_left:t3: :fist_left:t3: :fist_right:t3: :fist_right:t3: :fu:t3:


Sorry for the trouble.
While opening PDFs in PDF Archtiect can be a bit slower than in other applications (since all editing tools are loaded at startup), what you describe sounds like something is wrong. Is it installed on the same drive as the other viewers are / used to be? What kind of hardware are you running PDF Architect on? Which version of PDF Architect 4 do you have exactly? There might be a free update to e.g. 4.x which solves some of the issues. You can disable the desktop notifications completely in the general section of the PDF Architect options, we can totally understand you wouldn’t like to purchase an update as long as there are unresolved issues in your current install.

Best regards


Hello Robin,

Opening PDF Architect is not the problem, but opening the PDF is.

I have a
Dell XPS L502X
Intel i7-2630QM 2…0 Ghz
6GB of RAM
Windows 10 Pro
Sandisk 512GB SSD (SD8SB8U512G1122)

Application are installed and ran from C Drive, no other drives.

I have all modules (minus OCR) checked.
v. 64-Bit

Opening a Single Page PDF took
1m 42s 57
File Size: 90.3 KB
Single PDF with Image (not even vectors / objects / text), just a flattened PDF.

It should not take that long!


thanks for the feedback. It is hard to tell why loading the PDF takes such a long time, without taking a closer look at the situation, but opening a 90 KB PDF while PDF Architect is running shouldn’t even take seconds. As first attempt to resolve this, please try disabling the image filtering and GPU accelerated graphics in the “Graphics” section of the PDF Architect options.If you like, you could also install PDF Architect 5 (the basic/view module is free and it can be installed parallel to PDF Architect 4) to check if it faces the same issue.

Best regards,


Will try that later tonight. GPU acceleration is already off but problem still persists.

Hello Robin,

I am able to open the said file in PDF Architect 5 (no modules; GPU Acceleration && Image Filtering == Off). Took mere seconds. I tried again in PDF Architect 4, sorry, no go. Still over a minute. :frowning:

I uninstalled PDF Architect 4. Re-installed (some problems downloading modules). Without the modules installed, it was loading the PDF really really fast.

When the modules were loaded (installed), opening a PDF is now back to minutes. :frowning:


thanks, I have also tested the version on my machine here to make sure there is really no general issue, a modestly complex ~1MB PDF loads in less than a second here and it’s not even loading from an SSD, with all modules installed.
So it seems there is some kind of unusual compatibility issue between PDF Architect 4 and your machine.
I have sent you a key for PDF Architect 5 Pro+OCR, please check if you are still encountering the issue in PDF Architect 5 after installing the additional modules

Best regards


Entered and pasted key, closed PDF Architect 5, opened PDF Architect 5, loaded PDF, PDF loaded in a second

I am happy to hear the update solved the issue, sorry for the trouble.

Odd too is that, a) In PDF Architect 5, there is a “sign in” button to the top right, this is for e-sign I guess. I just signed on; when opening PDF Architect itself, it has a lag now (not opening PDF). Seems like it is hung on the same loading thread, querying the Internet? Not sure. I just logged off and back to normal, i.e., quick response, PDF Architect 5 opened quick, PDF opened quick.

PDF Architect 4 did not have the “Sign-In” Feature so I doubt it is that affecting it. Kinda odd that when loading… the thread gets “frozen” momentarily because it is busy querying the internet, thus, hanging the whole application until it is ready but the feature being queried for is not really an essential part of application loading.

Just my 2 cents.