PDF Architect 5 Standard and Pro freezes and cannot close

I am using both Standard and Pro in a business setting on multiple machines. I have clients calling me because PDF Architect will freeze and cannot be closed unless you “End Task” within Task Manager. This happens at random times, anywhere from one to multiple PDFs can be open. We are running HP Probook 430 G3’s with Windows 10, i5-6200U @ 2.3GHz with 8GB DDR4 so I know I have enough power and memory. Any advice that could help rectify this will be greatly appreciated. This is a daily occurrence for my PDF power users.


sorry for the trouble,
I am afraid we haven’t heard of this yet, so there is no known problem/solution.
It might help to disable the GPU accelerated graphics in the Graphics section of the PDF Architect options. Is the latest update installed (

Best regards,


Hi Robin,

Thanks for the response, the update must be a new one because that was the first thing I tried and it said I was up to date. I installed this update and disabled the GPU accelerated graphics (I was wondering about that one in the first place), so far so good. I should have a clearer idea tomorrow when the power users really put it to the test, I’ll let you know.

Thanks again,



We have the same Problem here. Disable GPU acc does not help.

After closing ALL pdfarchitekt processes it works for a random time.

System Win10 1607. Last Update installed.

Best regards


Hi all
Same problem here version 5 on Windows 10 PRO with 8 gigs of RAM; the only way to close the program is with task manager, very annoying

Same problem here!

As annyone solved this problem?


does the crash happen at random times, or when performing certain actions?
Please try to reinstall PDF Architect in case the issue is caused by an installaton problem; so far we haven’t been able to reproduce the issue on our test systems. Does the Windows Event manager log any informaton about the crash? I will ask our devs which logs might help to troubleshoot this problem and update the thread accordingly.
Sorry for the trouble.

Best regards,



I have the same issue .

Windows 10 64 bit, PDF architect 5 build 5.0.2834044 64bits and when I open a document it is impossible to qui PDFArchitect .

i have to kill the Task to qui it ?

I have reinstall PDFArchitect, it work a while and then same problem .


We have the same problem on a month old dell laptop i5 8GB ram, intel HD 620 graphics, win 10 1709. Just freezes, need to kill it in task manager, no log of freeze or chrash, happening on random…
Updated everything we could think of…

We also have this issue on a few desktops with the pdf Architect 6 on windows 7. i will try to disable the GPU accelerated graphics and see if that help. It also seems to be when they use single windows and not tab.