PDF Architect 8: not able to print

I have recently purchased the PDF Architect 8 Standard version, but since last Monday, I am not able to print any document from PDF Architect.
When I open a PDF file and hit print, it only shows a blanc page where there are no printing options.
At first I thought it may take a minute for the page to load, but nothing shows up.
I have figured out that when I uninstall the program en re-install it, it works. But when I close the program and re-open it, it stops working.
So now I have to uninstall and re-install the program every time I need to print.
I have purchased the program for 2 users and my colleague has the exact same issue.

Can this be a bug in the system?
What would be the solution for this?

Thanks!

I have been having the same problem with PDF Architect 8 Professional Version..

What would be the solution?

Thanks

Same issue here with v.8. No response in 10 days is concerning.

It concerns me too that there has been no response in 10 days... I am not sure if there is any other way to contact a support unit regarding this issue?

Same issue here - any advice on how to solve this would be kindly appreciated.

Same issue. Any solutions?

Hi PDF Forge Support Team

We have the same issue with PDF Architect 8. We can't print, blank page.
Any updates available or in the pipeline?

May you please communicate and show some loyalty to your paying customers..

Thanks!

Best wishes

I am glad to hear that I am not the only one, however this issue is really annoying.
Even more annoying is the fact that there is still no answer from a support tea. I have posted this issue a month ago, you should think they would indeed show some loyalty to their customers by now.
If there is anyone here who knows the solution to this issue, it will be much appreciated.
Or if anyone knows another way to contact the support team besided this forum, that would be great too...

I‘ve started the request as well here:

pdfarchitect[dot]org via Support Page.

Hi guys

after a long back and forth I finally received a solution that works.

Make sure all PDF Architect processes are stopped and then delete the following file "C:\Program Files\PDF Architect 8\plugins\plugin-spelling-checker.dll"

Then startup PDF Architect and then be surprized that it all works again!
According to support a fix is in the works.

Best
Simon

Hi Simon,
Thank you for your message.
I have deleted the plugin you mention and now it works again!
Thanks, really appreciated!