Pdf creator not in printers list

I have deleted the original download because of suspected ad installers, and now reinstalled.  However pdf creator does not appear as a printer, and there seems no way to correct this.  Help anyone?



please post you setuplog.txt from the main PDFCreator folder here (using the "paste as text button), or send it to support(at)pdfforge(dot)org and we will have a look at it.

best regards,

Same problem here.
After réinstallaing PDFCreator 1.7.3 (Please don’t ask us to switch to v2.2), no PDF printer is available.

Here is the setuplog.txt file

----- Setup - Start: 2016-01-08 13:38:18 -----
Install PDFCreator: 1.7.3
InstallerDirectory: C:\temp
X64: yes

Start AnalyzeCommandlineParameters
 Parameter /VERYSILENT: false
 Parameter /SILENT: false
 Parameter /FORCEINSTALL: false
 Parameter /REMOVEOPTIONS: false
 Parameter /EXPERT: false
 No Parameter /LoadInf
 No Parameter /SaveInf
 No Parameter /REGFile
 No Parameter /PPDFile
 No Parameter /Printername
End AnalyzeCommandlineParameters

WindowsVersionNumber: 6.0.6002
Silent installation: false
GUITS (7000, 50): 13
Update: 0
Installed PDFCreator version: 1.7.3
Installed PDFCreator version is lower 1.5.1 = false
nationCode: 84
InstallPDFCreatorPrinter = false
OS: 2
AppPath: C:\Program Files (x86)\PDFCreator
InstalledPDFCreatorVersion: 1.7.3
DontInstallPrinters: true
SPT: false


— Systeminformation - Start —
Windowsversion: 6.00.6002
WinDir: C:\Windows
Win64: true
ProcessorArchitecture: X64
.Net 2.0: true
.Net 2.0 regasm.exe:C:\Windows\Microsoft.NET\Framework\v2.0.50727\RegAsm.exe
SystemDir: C:\Windows\system32
TempDir: C:\Users\ZEN~1.PLA\AppData\Local\Temp\2\
CurrentDir: C:\Windows\system32
Computername: SERVEUR
Username: zen
UILanguage: 1036
Internet Explorer version: 9.0.8112.16421
Path: C:\ProgramData\Oracle\Java\javapath;C:\Windows\system32;C:\Windows;C:\Windows\System32\Wbem;C:\Windows\System32\WindowsPowerShell\v1.0\;C:\Program Files (x86)\Dell\SysMgt\oma\bin;C:\Program Files (x86)\Dell\SysMgt\idrac;C:\Program Files (x86)\Dell\SysMgt\shared\bin;C:\Program Files\Windows Imaging\;C:\Program Files (x86)\Microsoft SQL Server\100\Tools\Binn\VSShell\Common7\IDE\;C:\Program Files (x86)\Microsoft SQL Server\100\Tools\Binn\;C:\Program Files\Microsoft SQL Server\100\Tools\Binn\;C:\Program Files (x86)\Microsoft SQL Server\100\DTS\Binn\;C:\Program Files\Microsoft SQL Server\100\Tools\Binn\Redist\
C:\Windows\system32\Wbem\framedyn.dll: NOT found
framedyn.dll: found in path
— Systeminformation - End —

— Environment - Start —
CommonProgramFiles=C:\Program Files (x86)\Common Files
CommonProgramFiles(x86)=C:\Program Files (x86)\Common Files
CommonProgramW6432=C:\Program Files\Common Files
Path=C:\ProgramData\Oracle\Java\javapath;C:\Windows\system32;C:\Windows;C:\Windows\System32\Wbem;C:\Windows\System32\WindowsPowerShell\v1.0\;C:\Program Files (x86)\Dell\SysMgt\oma\bin;C:\Program Files (x86)\Dell\SysMgt\idrac;C:\Program Files (x86)\Dell\SysMgt\shared\bin;C:\Program Files\Windows Imaging\;C:\Program Files (x86)\Microsoft SQL Server\100\Tools\Binn\VSShell\Common7\IDE\;C:\Program Files (x86)\Microsoft SQL Server\100\Tools\Binn\;C:\Program Files\Microsoft SQL Server\100\Tools\Binn\;C:\Program Files (x86)\Microsoft SQL Server\100\DTS\Binn\;C:\Program Files\Microsoft SQL Server\100\Tools\Binn\Redist\
PROCESSOR_IDENTIFIER=Intel64 Family 6 Model 26 Stepping 5, GenuineIntel
ProgramFiles=C:\Program Files (x86)
ProgramFiles(x86)=C:\Program Files (x86)
ProgramW6432=C:\Program Files
— Environment - End —

----- Setup - End:   2016-01-08 13:39:43 -----

Has this issue been resolved?

Had a similiar problem with V2.2 on Win7 - probably the automatic installation failed due to non-signed drivers. Try adding the printer manually: Add Printer / Local / PDFCreatorPort and choose the GhostPDF driver from PDFCreators Ghostscript directory …

I’m on XP with the same issue after upgrading to 2.2.2. Setup log has been emailed, thanks.

I then installed using the method suggested by rkbwde above. I got an error message from the Printer Driver Setup Wizard: “Printer driver was not installed. The process cannot access the file because it is being used by another process.” But after that I saw the printer was installed after all.

(I still had the same trouble as pointed out in another thread where the document prompted to save but with no output file. I opened PDFC several times with the same save prompt but no file. In the end it did save however.)

Thanks rkbwde, manually creating the printer worked.

Original problem was the Printer was originally working without problems. And suddenly stopped working for the user.

Note: Changes to Antivirus was set to high, which blocked and deleted ghost script. Adding ghost script to safe programs fixed the problem from happening again

Same problem here :frowning:

Hi, please try the following to fix the problem:

1. Check if there is still an entry for PDFCreator in the "Programs and Features" section of the windows control panel. If there is, please use this to uninstall any remainders of PDFCreator. If the uninstall is successful, reboot your machine and check if the pdfcmon.dll got deleted from windows\\system32. If yes, simply run the latest PDFCreator setup and hopefully the problem will be solved. 

2.  If step 1 didn't solve the problem and the pdfcmon.dll didn't get deleted during the uninstall, run cmd.exe as admin and then enter the command "net stop spooler".

Go to Windows\\system 32 and delete the pdfcmon.dll manually, then run the command "net start spooler". Then run the latest version of the PDFCreator setup and the problem should be solved.


If all this doesn't help, please let us know.

best regards,

Most probable is that some Windows service is not running.
Check the services:
"Device Association Service"
"Device Install Service"
"Device Management Enrollment Service"
"Device Setup Manager"
"Print Spooler service"
None of them should be disabled, at leat they should be on manual.