PDF Creator problems after 1.7.0 upgrade

I am starting this as a new discussion because I have gotten no response when I posted to already existing threads.  I have a Windows 7 64 bit machine that we started having problems with PDF Creator with a couple of weeks ago.  We use PDF Creator to print to TIF.  When we try to do this, we don’t get any error messages or anything, but the TIF file does not get created.  It appears it maybe creating a blank page.  I think I discovered this if I set it back to print to a PDF then a blank page shows up.  It seems like it may have been triggered either by a Windows update or by the upgrade to 1.7.0.  But, I have tried uninstalling and reinstalling the old version and still get the same problem.  Any input from PDFforge would be greatly appreciated on this. 

Hi,

do you have LZW (zip) compression enabled for .tif files?
If yes, please try if disabling/changing this solves the problem.

regards,

Robin

I actually had downgraded to version 1.6.2, so I don't think the LZW compression was the problem.  I did some more testing and it seems to be related to the file name being blank when you go to save the file.  If I set the format to TIF and the filename is blank, even though I put a filename in there, it does not save the file.  If I set the format to PDF, then it does appear to save the file, but it is actually just a blank page.  Do you have any idea what would cause this in version 1.6.2? 

 

I tried uninstalling and reinstalling 1.6.2 again and still got the same issue.  I then upgraded to 1.7.0 and it works, except for the LZW format.  So, I chose a different binary format and it seems to work.  I am still concerned that we may run into issues in our Document imaging Software with the other format, but we will give it a try.

did you happen to have non ascii chars in your filenames?

I too am having this problem on 64bit Win7. Was using very old version and decided to update (1.7.0)  Test page works fine.  Printing from any other app. generates a 3KB blank page.  Not using any non-ASCII chars.  Open notepad, type some text and print to pdfcreator -> blank page.

Log:
5/16/2013 1:21:55 PM: PDFCreator Program Start
5/16/2013 1:21:55 PM: Windowsversion: Windows 7 [6.1 Build 7601 (Service Pack 1)]
5/16/2013 1:21:55 PM: InstalledAsServer: False
5/16/2013 1:21:55 PM: MyAppData: C:\Users\jerry\AppData\Roaming
5/16/2013 1:21:55 PM: PDFCreator spool directory (Write access: true): C:\Users\jerry\AppData\Local\Temp\PDFCreator\Spool\
5/16/2013 1:22:29 PM: Ghostscriptparameter:
-IC:\Program Files (x86)\PDFCreator\GS9.07\gs9.07\Lib\
-q
-dNOPAUSE
-dBATCH
-sFONTPATH=C:\Windows\Fonts
-sDEVICE=pdfwrite
-dPDFSETTINGS=/default
-dCompatibilityLevel=1.4
-dProcessColorModel=/DeviceCMYK
-dAutoRotatePages=/PageByPage
-dCompressPages=true
-dEmbedAllFonts=true
-dSubsetFonts=true
-dMaxSubsetPct=100
-dConvertCMYKImagesToRGB=false
-sOutputFile=C:\Users\jerry\Documents\test1.pdf
-dEncodeColorImages=true
-dAutoFilterColorImages=true
-dEncodeGrayImages=true
-dAutoFilterGrayImages=true
-dEncodeMonoImages=true
-dMonoImageFilter=/CCITTFaxEncode
-dDownsampleMonoImages=false
-dPreserveOverprintSettings=true
-dUCRandBGInfo=/Preserve
-dUseFlateCompression=true
-dParseDSCCommentsForDocInfo=true
-dParseDSCComments=true
-dOPM=0
-dOffOptimizations=0
-dLockDistillerParams=false
-dGrayImageDepth=-1
-dASCII85EncodePages=false
-dDefaultRenderingIntent=/Default
-dTransferFunctionInfo=/Preserve
-dPreserveHalftoneInfo=false
-dDetectBlends=true
-f
C:\Users\jerry\AppData\Local\Temp\PDFCreator\Spool\9DC1C21A2601455686F2B5E12FA5B6C8.mtd
5/16/2013 1:22:29 PM: Time for converting [PDF without encryption]: 00:00:00:087

More information:
It looks like it might be passing the wrong file name to ghostscript.  I see an .inf file and an .ps file in the spool directory but the log shows it is looking for an .mtd file.

After creating the empty .pdf file, the .inf file is deleted but the .ps file is not.

Any ideas?

Mine is now working fine in 1.7.0.  I completely uninstalled, reinstalled version 1.6.2.  Still had the issue there, but then upgraded to 1.7.0 and don't have the issue.  I still couldn't print to TIF with the LZW format, but everything else works. 

 

I think somehow the issue is tied to the file name coming up blank.