PDF Creator unable to open

Hello, I am having some issues with PDFCreator, here is an overview of the issue.

I have 2 users that have had PDFCreator 1.2.3 on their WIN10 PC, we use that version because it works for the PrinterServer, we tried to update in the past, but have had some issues with the new versions.

We have some specific configurations, that we input once the software is installed, that want PDFCreator to generate.

On the WIN10 PCs, when you try to launch it, the program shows up in the Task Manager, but then exits a second later

Last report it was working Nov 6th, then on the 9th, the program fails to load.


I have installed PDFCreator 1.2.3 on a WIN7 pc and had them test it, for a few days it worked then we got this error

PDFCreator has stopped working>>

Problem signature:
Problem Event Name: APPCRASH
Application Name: PDFCreator.exe
Application Version:
Application Timestamp: 4e684671
Fault Module Name: hmpalert.dll
Fault Module Version:
Fault Module Timestamp: 5f5a1bec
Exception Code: c0000005
Exception Offset: 00016d35
OS Version: 6.1.7601.
Locale ID: 4105
Additional Information 1: 2f4c
Additional Information 2: 2f4c09976b5535da63af9f51bb6bbf08
Additional Information 3: 4a9f
Additional Information 4: 4a9f769dd8b710916912857b58ba9701

I then tried to install it on a second WIN7 PC, it worked NOV 10th to 13th and now this PC has the same crash error as the other WIN7 PC


My organisation has recently started seeing the same issue with version of PDFCreator, with the same fault codeand offset. Suspending the HMPAlert process prevents this issue from happening. We have tested we version 4.6.2 of PDFcreator which works however we have a requirement to use older versions.

@nictsupport Are you able to confirm the versions of Sophos and HMP you have installed on affected PCs?

Any feedback would be appreciated.

Currently I can see that I am running
Core Agent 2.10.7
Endpoint Advanced
Sophos Intercept X 2.0.18

I wasn't entirely sure about the Hitman Pro alert, seems I might have missed that.

My current solution is running PDF Creator 1.2.3 on a Laptop w WIN10 and excluding it from WSUS updates, so far its been working for 2 weeks.

Thanks for the info.

We have been able to workaround the issue by suspending the HMP process within Windows if that is of any use to you.

I am going to try that and see, and particular steps you used?

Good thing is we are done with this type of printing at the end of the year.

Thanks DMS