I am not sure how PDFArchitect is meant to work but I can't get a PDF to actually appear is the window, either when opened through the PDFCreator print process of directly launching the program. I am running Vista Business x64.

Also, it would be nice to be able to remove/hide the option to "Edit PDF files with PDFArchitect" in the PDFCreator print window. It is just another option for me to accidentally click when printing, especially as the clickable area extends across the window above the Save button.


I have found the problem. It was a wrong translation mapping in the english file. The fix now is included in the nightly version of PDFArchitect:


It will also be included in the version 1.3.1 of PDFCreator that we will release in the next days.

kind regards,

After which I can click the "continue" button and now I have 2 not-quite-open documents, and get the above error message each time I switch between them.

If I switch the language to German, any further file actually opens, so I can have a mix of open and not-quite-open documents.

I have the same result as well as Architect terminating with an error.

PS -- that is testing under WinXP SP2 X64 -- haven't tested it under other Win versions at this point.

Tested also Windows 7 x86, x64 and in XP Mode.

PDFArchitect only works when its UI language is set to German.

 Same problem with Vista 64 bit. Workaround using German UI works.



do you get any error messages? 

There is no error message. The status bar says "1 document(s) successfully loaded" but the pager says 0/0 and no pages are shown. If I attempt to open a second file, the following error is shown:


See the end of this message for details on invoking
just-in-time (JIT) debugging instead of this dialog box.

************** Exception Text **************
System.NullReferenceException: Object reference not set to an instance of an object.
at pdfforge.PDFArchitect.MainForm.pdfDocumentControl_SelectedIndexChanged(Object sender, EventArgs e)
at System.Windows.Forms.TabControl.OnSelectedIndexChanged(EventArgs e)
at System.Windows.Forms.TabControl.WmSelChange()
at System.Windows.Forms.TabControl.set_SelectedIndex(Int32 value)
at pdfforge.PDFArchitect.MainForm.openFiles(String[] files)
at System.Windows.Forms.ToolStripItem.RaiseEvent(Object key, EventArgs e)
at System.Windows.Forms.ToolStripItem.HandleClick(EventArgs e)
at System.Windows.Forms.ToolStripItem.HandleMouseUp(MouseEventArgs e)
at System.Windows.Forms.ToolStrip.OnMouseUp(MouseEventArgs mea)
at System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
at System.Windows.Forms.Control.WndProc(Message& m)
at System.Windows.Forms.ToolStrip.WndProc(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

************** Loaded Assemblies **************
Assembly Version:
Win32 Version: 2.0.50727.5448 (Win7SP1GDR.050727-5400)
CodeBase: file:///C:/Windows/Microsoft.NET/Framework64/v2.0.50727/mscorlib.dll

Assembly Version:
Win32 Version:
CodeBase: file:///C:/Program%20Files%20(x86)/PDFCreator/PDFArchitect/PDFArchitect.exe

Assembly Version:
Win32 Version: 2.0.50727.5446 (Win7SP1GDR.050727-5400)
CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System.Windows.Forms/

Assembly Version:
Win32 Version: 2.0.50727.5453 (Win7SP1GDR.050727-5400)
CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System/

Assembly Version:
Win32 Version: 2.0.50727.5420 (Win7SP1.050727-5400)
CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System.Drawing/

Assembly Version:
Win32 Version:
CodeBase: file:///C:/Program%20Files%20(x86)/PDFCreator/PDFArchitect/DynamicTranslator.DLL

Assembly Version:
Win32 Version:
CodeBase: file:///C:/Program%20Files%20(x86)/PDFCreator/PDFArchitect/DataStorage.DLL

Assembly Version:
Win32 Version:
CodeBase: file:///C:/Program%20Files%20(x86)/PDFCreator/PDFArchitect/Gnostice.PDFOne.DLL

Assembly Version:
Win32 Version: 2.0.50727.5420 (Win7SP1.050727-5400)
CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System.Xml/

Assembly Version:
Win32 Version: 2.0.50727.4927 (NetFXspW7.050727-4900)
CodeBase: file:///C:/Windows/assembly/GAC_MSIL/Accessibility/

************** JIT Debugging **************
To enable just-in-time (JIT) debugging, the .config file for this
application or computer (machine.config) must have the
jitDebugging value set in the system.windows.forms section.
The application must also be compiled with debugging

For example:


When JIT debugging is enabled, any unhandled exception
will be sent to the JIT debugger registered on the computer
rather than be handled by this dialog box.


Did you dl the nightly build and it still didnt work? ( I only ask because there is only 1 minute between your last post and the post introducing the fix;)

 PDF Architect works fine when the PDF document has only few pages but fails to load a 15 page scanned document. It loaded the first 9 pages and the rest were left blank.

I am using Win XP service pack 3. 

I tried the same on a Windows 7 laptop, It was able to load all the pages but excruciatingly slowly and more so towards the last pages.

Please fix it since what the program does is a great solution for me.


Running Win7-64.  Loaded large 207 page PDF file.  All pages appear blank. Same results with 0.5.5 or  Small PDF files load fine.