Pdfcreator 2.0.1 - Difficulty printing over network


I have upgraded my PDFCreator 1.7.x to 2.0.1.

I have been able to get it operating on my print server sporadically, but now it does not seem to be acting right at all.

I can still print locally, and I can run the program as localsystem and print test pages, but I am not seeing anything come through via network printer.

I have created a new printer with a new profile, still no-go.

At one point I saw the dialog “a program is requesting attention” and it switched to the PDFCreator GUI on the print server, however that has not done this lately.

I have uninstalled, rebooted, and reinstalled (twice) with a manual deletion of the PDFCreator folder from C:\WINDOWS\TEMP, as well as the PDF…net folder

I can see the remote print job come to the print queue and disappear again.

Updating now to 2.0.2 to see if anything is fixed.

Same behavior with 2.0.2 – the client PC shows the job go to the print server, the print server shows the job appear and disappear, but the file does not write out to the drive.

OK… very strange :slight_smile:

To test settings I run PDFCreator off a local system command prompt (the context the spooler runs in for network).

The profile didn’t exist in this context, so I recreated and applied it to the printer.

When I launch the PDF Creator GUI from the command prompt (so it’s running as local system) I can print the PDFCreator test page, but the windows test page fails, notepad print to the named printer fails, and the debug log shows nothign from those jobs.

I have the same problem since version 2.0
Why the server mode installation have been flush?

Same problem. Windows7-Server2008R2

I’d be willing to get paid version if I was sure it was working there.

Ok, I found answer

So go back to 1x or wait N amount of months

I am afraid there is no server mode available in version 2.0 anymore, but we are planning to create a proper windows service instead.


yes that is correct, the old way of forcing a desktop application into server mode didn’t seem like the best approach so we decided to go for a separate service instead. It is already being worked on. But for now, the latest version with a server mode is 1.7.3.

best regards,