PDFCreator 2.3.2 will not install due to failed uninstall of prior version

I am on Windows 10. I uninstalled the old PDFCreator program, and it no longer appears in the installed program list. I then tried to install the new version (2.3.2) and get this error:

PDFCreator is already installed, it is necessary to uninstall the existing installation (version 0.0.0) before installing PDFCreator 2.3.2.

Version 0.0.0? Where is that coming from? When I click Yes to continue the installer, I get this message:

Runtime Error (at 309:207): Internal error: An attempt was made to expand the "app" constant before it was initialized.

I have found others with similar problems trying to install, and the advice was either to uninstall the prior version (which I did, but remnants still remain in the registry it seems), or to try a Forced install. So, I setup a shortcut to run the installer in Forced mode: PDFCreator-2_3_2-Setup.exe /ForceInstall

This too gives the same errors as above. I then downloaded and ran the Revo Pro Uninstaller program, but couldn't get it to find the old version to clean up. I'm guessing there is a registry entry somewhere that needs deleting, but what is it?

I’m also having problems installing PDFCreator 2.3.2. Slightly different problem:

  1. Windows 7 Pro x64

  2. The error message I get pops up right after choosing the install language (English).

  3. The message is: “Please restart your system first to continue setup”.

  4. Restart the machine, same error.

  5. Uninstall all previous versions of PDF Architect AND pdfCreator, then restart the machine, same error.

  6. From the commandline, run PDFCreator-2_3_2-Setup.exe /ForceInstall, same error.

I can’t think of what to try next. Tech support, please help!

Well, I seemed to have fixed my problem. I tried CCCleaner to remove registry keys for PDFCreator, but that still did not allow installing 2.3.2 version. I found another thread about installing an older version, so I downloaded 1.7.3 to try that one.

Search for "download version 1.7.3" in the forum. It won't let me put links here. Or copy and paste this in your browser:

Where can I download version 1.7.3?

It too told me version 0.0.0 needed to be removed first, and asked to continue uninstalling and updating. I clicked OK and this time it actually removed the old version and installed 1.7.3. After that I restarted the computer, then uninstalled 1.7.3, then restarted again. Then I tried 2.3.2 and it worked.

I’m hoping that PDFcreator tech support will jump in here. As it turns out, I paid for a 3-year PDFcreator Plus license just before I ran into this problem. I hope there’s a solution other than downgrading to v1.7.3.

I needed it to work ASAP and was exhausting all ideas in case nobody else could tell me how to fix it. Turns out 1.7.3 was just a means to an end. My computer is now working on 2.3.2.

Also, If you paid for a license, then I’d say email support and don’t wait on a forum response. Or try the solution that worked for me.


Thanks, Scott! I was able to install 1.7.3 successfully, but encountered the same error afterwards when trying to install 2.3.2. I’ll follow that link to email support.

Regards, Jeff


  1. The link above to PDFcreator Plus does not provide the contact info for PDFcreator Plus support. However, here it is: support@pdfforge.org

  2. To solve this problem, there is a orphaned registry key that must be deleted. The key is:

  3. The key will likely be in one of these two registry locations:

  4. Delete the key, the v2.3.2 will install properly.

1 Like

For PDFCreator developers: This problem has happened again (with 2.3.2?). The solution above fixed the problem.


do you mean when updating from 2.3.2 or updating to version 2.3.2? We obviously can’t do anything about the old versions, but it shouldn’t happen when updating from 2.3.2 to 2.4.0 or similar.

Best regards


Yes, this problem happened to me when I upgraded from 2.3.x to 2.4.1. Also, it happened again when I upgraded from 2.4.1 to 2.5.1.


thanks for the feedback and sorry for the trouble.
We will look at this again and run some more extended tests to find our under which conditions this happens, it is not the default behaviour and not instantly reproducible on the test machines.

Best regards,


For PDFCreator developers: The problem happened again when I upgraded PDFCreator Plus from version 2.5.1 to 2.5.2. I had to delete the same registry key (see up-thread) before the upgrade would install.


thanks for the feedback, but we will still need to find out why this happens on some machines; you aren’t the only one experiencing this issue, but most users don’t get this problem and we can’t reproduce it on our test machines. We will look into possible reasons for this and see if there is anything we can improve to prevent this from happening.

Best regards,


After my last post I noticed that the problem occurs for me if I download and attempt to install the update through the automatic PDFCreator prompts. On the other hand, if I simply go to the PDFcreator website and download the update and then install the downloaded update, the problem is avoided.

I am running a Windows 10 domain-bound laptop for work. I uninstalled PDFCreator version 3.2.0 which called for a restart. Restarting does not resolve the issue
I tried removing the HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\RunOnce key and it gives me a non-descript error that it cannot delete the key
My system doesn’t have an HKLM\SOFTWARE\Wow6432Node folder at all


I don’t know how this can happen, but if it isn’t possible to delete the key, the setup will always assume it requires a restart. It might be possible to work around the issue by running the setup with the parameters /NORESTART and /SILENT (no restart only works with silent). Otherwise you will need to find out why the key can’t get deleted from the registry, keys in the runonce section are usually deleted by the system once the have been run once, so there seems to be an issue outside of PDFCreator here.

Best regards