PDFCreator 4.1.0 COM Interface is missing/broken

I'm using the COM interface from a Visual Foxpro program and with the latest PDFCreator version 4.1.0 has stopped working.
The PDFCreator.PDFCreatorObj and PDFCreator.JobQueue objects are no more instantiable.

3 Likes

Yes, I also noticed and needed to downgrade to 4.0.4 version. I'm waiting for news.

1 Like

Same using COM from c++

1 Like

Bei mir funktioniert es auch nicht.

Benutze VBA unter Excel.
In der alten Version ist alles OK.

Heinz

1 Like

Seems to be broken in 4.1.0 for me, too. Running the supplied COM_TestForm, I'm getting the following exception on the Activator.CreateInstance(queueType) call:

Could not load file or assembly 'System.Security.AccessControl, Version=4.1.1.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a' or one of its dependencies. The system cannot find the file specified.

Visual Studio 2017, .NET 4 revision 461814

thanks,
bruce

p.s. And it works fine in 4.0.4...

1 Like

We're experiencing the same problem using the com interface via .net. A fix would be extremely helpful!

1 Like

No news from PDFForge ?

1 Like

I have the same issue using the com interface with MS Access VBA and PDFCreator v4.1.0 Build 13336.
With PDFCreator v4.0.2 Build 10752 things work correctly!

When is PDFForge providing a fix?

1 Like

4.1.1 also does not work

seems that it needs System.Security.AccessControl, Version=4.1.1.0 (that's the exception) but System.Security.AccessControl.dll in installation folder is 4.1.3.0

1 Like

Yes, still not working in 4.1.1

New PDFCreator Version - same problem!
VBA macros do not work with the new version (4.1.1) either.

Therefore:
If you need the COM interface, do not install Vers. 4.1.1!

Hello everybody,

The issue has been fixed with version 4.1.2. We are very (!) sorry for the trouble:
https://download.pdfforge.org/download/

The blog post will be released soon.

Kind regards
Sascha

2 Likes

My code work with the version 4.1.2. Thanks for the fixe

With version 4.1.2 the VBA macros work for me again.
Many thanks to the team.

Who needs the COM interface:
--> install Vers. 4.1.2 or stay with 4.0.4.

Heinz

thank you very much!