PDFCreator doesn't print. Print error

 Howdy. I used to be able to print but can't now. I print a doc to PDFCreator, and nothing happens. I go to the printer queue and the job is listed with status="Error printer." I clear the queue of all printer jobs and get the same result. 

I turn the log file on, try to print, and the log file is empty.

I "print test page" from general settings and it prints fine and it shows up in the log file.

I have PDFCreator 1.2.3 and W7.

What next? Any help appreciated.

 

You wrote: "you MUST set ..." - the question is: WHERE (I found no possibility to set it...)

 Don't you have a C:\\Program files\\Pdf Creator\\ folder?

 Ops, sorry... now understand! Th espool directory is in another path that you don't know. I remember that there's a Registry key used to set this folder, maybe this help you. I don't understand what you mean about "Roaming profile", isn't your installation on a W7 os?

the path is set to "c:\\users\\administrator\\appdata\\roaming\\temp\\spool...."

Of course normal users cannot write there - but I cannot change this path.

Even deinstallation/new installation doesn´t change this path (even if installed by a different user!)

 Try to set permission in the PdfCreator spool directory.

I hope this help you, I had the same problem and solved it.

 thanks for the advice. Didn't work though. I stopped and re-started the spooler through Windows and then re-booted as well. Still the same; no print.

 Not the spool service, but the spool directory in c:\\program files\\PdfCreator\\

Sorry but now I'm not working in a Windows Seven OS.

The directory is configured (so you can see the ful lpath) in the PdfCreator settings utility.

 thanks for the continuing help and sorry I don't understand it all. 

I don't understand: "the spool directory in c:\\program files\\PdfCreator\\"  I go to that directory and see no spool directory there. The only thing I see is a pdfspool.exe file. I open it but nothing happens. 

I also don't understand "The directory is configured (so you can see the ful lpath) in the PdfCreator settings utility." I open the PDF print monitor and open options/general settings. I see nothing there about directory configuration. 

It's interesting to me that there is no pdfcreator.exe or other executable that looks like a root program. Guess that makes sense if this isn't a stand-alone program but some kind of driver. 

Maybe I should reinstall PDFCreator. What do you think?

thanks again

I have the same problem: I installed as administrator - and the spool directory is set to the roaming profile of that user instead to c:\\program files\\pdf creator\\

So no normal user can print (because lack of rights) - and I didn´t fin d any possibility to change that path.

Any help appreciated.

 

P.S.: I re-installed already several times - with sa,e result :-(

 Yes, you must have .exe files!

 

If you encoured in this problem you MUST set to the folder:

C:\\Program Files\\PDFCreator\\Temp\\PDFCreatorSpool\\

that users "Users" can read and write in this folder.

Hi,

I´m facing the same problem. I guess, it started with updating to the latest pdf-creator version.

I followed the instructions and now, I can read the Logfile.

However the print job still stops with error

Any advice? Thanks