PDFCreator printer not installed 4.0.4

I had a running PDFCreator 3.5
I thought it was a good idea to upgrade to 4.0.4
I had to uninstall 3.5 before running the setup for 4.0.4
After installation the program says that the PDFCreator printer was not installed.
I uninstalled PDF Creator with Revo uninstaller and got rid of all files linked to PDF Creator.
I reinstalled with the option "Run as administrator" .
Still no PDFCreator printer. The program offers to repair but fails.
What is wrong? 3.5 had a PDFCreator printer.
After uninstalling 4.0.4 I reverted to 3.5 and it works! The installation does install the PDFCreator printer.
I run W10 Pro (64) with the latest updates.
Ivar Suneson


sorry for the trouble.
While there is no known issue with the printer installation of PDFCreator 4.0.4, but there have been some small changes to how the printer gets installed, which might cause the issue on your system. For example, we have reduced the number of times we restart the spooling service, as this caused some delays and normally shouldn't be necessary more than once. If you'd like to give updating to 4.0.4 another try, we will be happy to help you resolve the issue.

Best regards