PDFCreator stuck when run through TaskScheduler


We're having an application (VS2005, C#) which runs on WS 2003 Rs SP2. the application starts the PDFCreator and prints documents etc.

Starting pdfcreator as follows:

_PDFCreator =

new PDFCreator.clsPDFCreator();

parameters =


"/NoProcessingAtStartup";_PDFCreator.cStart(parameters,true)This works perfecty fine when running the application manually . The issue is, I have to run it continuously and thats why it is defined in the TaskScheduler. Until two weeks ago this worked ok, but suddenly the application hangs at


Nothing happens, and also a try - catch doesnt give any results; it just hangs there. It might has to do something with permissions, but until now nothing has been found. Did someone encounter a similar issue? I also checked for DCOM issues, but everything was declared ok. Also Data Prevention Execution has been defined to allow for pdfcreator.exe + spooler. Also the user who runs the app can fully mange the pdfcreator. I tried to run the app also from account with Admin rights but to no avail. Did anyone encounter such a problem and how was it solved? Thanks, Alain