PDFCreator Terminal Server Settings Not Saving

I recently installed PDFCreator Terminal Server in our Citrix environment. I created the profiles and printers and assigned them accordingly. These profiles were for saving files to network directories for processing by a document management system. I was able to test printing from an application and all worked well. After we pushed from our Citirx master we were unable to save to the directories.

I went into the application on each Citrix server and discovered that the settings were not there. The printers transferred from the master, but the profiles did not. I recreated the profiles, assigned them to the printers, and re-tested the application. Everything worked fine.

I logged off the server and back on and the profiles had disappeared yet again.

Has anyone seen this? I'm sure I'm missing something completely obvious.


per default the settings are saved inside the user profile (while the printers are installed on the machine level), for Citrix usage best export them into a settings file as described here.

Best regards