PDFCreator + Thunderbird 64bit crashing every time


#1

Hello everyone,
I've been using PDFCreator and Thunderbird 32bit for a few years with no problem. Last days I switched to 64bit of Thunderbird. Now creating and sending pdf to email client is crashing Thunderbird every time.

My specification:
Windows 7 Ultimate SP1 64bit
Thunderbird 65.0b1 64bit
PDFCreator 3.3.2 Build 3528

I'd like to stay with 64bit version of Thunderbird because it's notable faster for me.

Thanks in advance for any help.


#2

Hi @user123 (great name! :grin:)

I just tried it with Thunderbird 65.0b2 and had the same issue.

The PDFCreator Log shows the following:

Log Output

2019-01-16 11:32:36.9268 [Info] 2824-10 (ProcessingThread) pdfforge.PDFCreator.Conversion.Actions.Actions.EMailClientAction.ProcessJob: Launched client e-mail action
2019-01-16 11:32:36.9376 [Info] 2824-10 (ProcessingThread) pdfforge.PDFCreator.Conversion.Actions.Actions.EMailClientAction.Process: Launched client e-mail action
2019-01-16 11:32:36.9376 [Info] 2824-10 (ProcessingThread) pdfforge.PDFCreator.Conversion.Actions.Actions.EMailClientAction.Process: Starting e-mail client
2019-01-16 11:32:36.9600 [Info] 2824-10 (ProcessingThread) pdfforge.Mail.MapiClient.ShowEmailClient: Launched client email action
2019-01-16 11:32:36.9737 [Info] 2824-10 (ProcessingThread) pdfforge.Mail.MapiClient.ShowEmailClient: Start MAPI processing
2019-01-16 11:32:36.9737 [Info] 2824-10 (ProcessingThread) pdfforge.Mail.MapiMailMessage.ShowDialogInOwnThread: Creating MAPI thread
2019-01-16 11:32:36.9737 [Info] 2824-14 () pdfforge.Mail.MapiMailMessage._ShowMail: Showing mail client
2019-01-16 11:32:36.9737 [Info] 2824-14 () pdfforge.Mail.MapiMailMessage._ShowMail: Subject:
2019-01-16 11:32:36.9737 [Info] 2824-14 () pdfforge.Mail.MapiMailMessage._ShowMail: Adding 1 files
2019-01-16 11:32:36.9835 [Info] 2824-14 () pdfforge.Mail.MapiMailMessage._ShowMail: Starting MAPI call
2019-01-16 11:32:36.9835 [Info] 2824-10 (ProcessingThread) pdfforge.Mail.MapiClient.ShowEmailClient: Done with MAPI
2019-01-16 11:32:36.9835 [Info] 2824-10 (ProcessingThread) pdfforge.PDFCreator.Conversion.Actions.Actions.EMailClientAction.Process: Done starting e-mail client
2019-01-16 11:32:36.9835 [Trace] 2824-10 (ProcessingThread) pdfforge.PDFCreator.Core.Workflow.JobRunner.CallActions: Action EMailClientAction completed
2019-01-16 11:32:36.9835 [Debug] 2824-10 (ProcessingThread) pdfforge.PDFCreator.Core.Workflow.JobRunner.CleanUp: Cleaning up after the job
2019-01-16 11:32:36.9835 [Trace] 2824-10 (ProcessingThread) pdfforge.PDFCreator.Core.Workflow.JobRunner.RunJob: Job finished successfully
2019-01-16 11:32:36.9991 [Trace] 2824-10 (ProcessingThread) pdfforge.PDFCreator.Core.Workflow.JobRunner.RunJob: Calling job completed event
2019-01-16 11:32:37.0362 [Debug] 2824-10 (ProcessingThread) pdfforge.PDFCreator.Utilities.Threading.ThreadManager.StartSynchronizedThread: Adding thread
2019-01-16 11:32:37.0938 [Trace] 2824-10 (ProcessingThread) pdfforge.PDFCreator.Core.Workflow.JobInfoQueueManager.ProcessJobs: Removing job from Queue
2019-01-16 11:32:42.1885 [Info] 2824-14 () pdfforge.Mail.MapiMailMessage._ShowMail: MAPI result was: -2147023170
2019-01-16 11:32:42.1885 [Info] 2824-14 () pdfforge.Mail.MapiMailMessage._ShowMail: Done with MAPI

Basically, the log tells us that PDFCreator starts Thunderbird using MAPI.

Since Thunderbird for Windows 64-Bit is still an unstable beta, you should consider reporting the issue to mozilla if they're not already aware of the issue.

As a workaround you can use the script action to start Thunderbird. Should look like this:


(Should work with the 64-Bit version, too. I don't have an account to test it on my virtual machine but the software didn't crash on start-up.)
You can use the command line arguments for Thunderbird. Find them here: http://kb.mozillazine.org/Command_line_arguments_(Thunderbird)


Print to Thunderbird not working after update
#3

Thank you for your response.
I reported the issue to thunderbird forum. The issue is known and the fix is on the way.

Workaround with script works with TB 65 beta 3 x64. Thanks for tip!


#4

Hi!
In latest TB beta creating and sending pdf to email client works good. No workaround needed.
I'm creating pdf file, then I'm sending it to PDFCreator printer with special setup. One action is printing on physical printer immediately, second action is open Thunderbird compose window with pdf attached and message content filled.

Problem solved with TB 65.0b4.

Windows 7 Ultimate SP1 64bit
Thunderbird 65.0b4 64bit
PDFCreator 3.3.2 Build 3528