PDFCreator Win Server 2008 Startup

Is there away to ensure that PDFCreator runs on server startup?  I have a job that reboots my server every night.  When it reboots, PDFCreator will not print PDFs until I log in start the .exe.  I have added it to the Startup folder and it still requires a local login to start.


This was asked here: http://www.pdfforge.org/forum/open-discussion/4746-pdfcreator-099-released#comment-967


Try to run PDFCreator as service.

Here is a link to an instruction from our old forum.



Install As Service, Working!

2006-08-30 01:26:59 by jmouse888

Running PDFCreator as a service is working!

After I RTFM for the instsrv and srvany, I finnaly got the PDFCreator running as a service on our server. For those don't want to RTFM, just follow these steps (may vary from version to version, ie. NT4 thru 2003):

  1. Install the PDFCreator server mode and make sure it's running correctly.
  2. grab the Resource Kit for your Windows server verison from Microsoft. Just do "Search" on Microsft's site. It's pretty popular.
  3. unpack/install the Resource Kit, and copy instsrv.exe and srvany.exe to C:\\WINNT\\SYSTEM32 (I like to use the system32 just in case the command is not in the PATH)
  4. install srvany.exe as a service by running following command at the prompt:

    `instsrv PDFCreator c:\\winnt\\system32\\srvany.exe`
  5. run regedit, and
    • go to HKLM\\System\\CurrentControlSet\\Services\\PDFCreator
    • Add a key "Parameters" under PDFCreator
    • in "Parameters", add a string (REG_SZ) value "Application"
    • assign the following to "Application"
      `"C:\\Program Files\\PDFCreator\\PDFCreator.exe"`
      (or wherever you installed the program)
    • Close regedit

  6. open your Service manager and locate PDFCreator
  7. go to the "Log on" property, ("Startup" button in NT4 and Property->"Log on" tab in Win 2000 and 2003)

  8. do ONE of the following

    • if you need the PDFCreator interface (monitor), select System Account and check "Allow service to interact with Desktop".
      This will show the main window and allow you to see the "queue/monitor". However, the application can be closed even if the primary service appears running.

    • if you don't need the monitor, do not check the "Allow interact...", or select This Account and use an admin user's login.
      Running the service this way will disable the primary interface, but you can still change settings and view logs by using the shortcut provided by the PDFCreator installation in the Start Menu.

  9. Make sure "Startup Type" is set to Automatic

  10. Start the service.

That's it! This will allow the program to run as a service , ie. with or without anybody logged in.



Thanks for the reply Frank!  It didn't intially work for me (probably because I'm using Server 2008) but in the end it got me here:



I'm now up and running!