Physical print from letter to A4


#1

Hello,

We have a process that creates a pdf, saves it and prints a physical copy to our printer with PDFCreator.

The issue we have is that the physical prints are letter size instead of A4.
The PDF's are ok.

It looks like Ghostscript always prints to letter?
Even when I "physical print" to a PDF the size is letter.

Is there a possibility to change that Ghostscript prints to A4?


#2

Hi,

which application is the document originally printed from?
Some applications have an option to automatically scale between letter and A4, which you might need to disable.
Ghotscript sends the same Postscript file that was used to create the PDF to the hardware printer without any adjustments.
You can use the "run script" action instead of the "print" action in order to print the actual PDF to the printer with a viewer of your choice, which should work around the issue if everything else doesn't help.

Best regards

Robin


#3

Hi,

The application is called mikrowin 2010 (lab software).
All I can change within the software are the margins the file is printed.
This is fine, because the PDF itself looks ok.

The strange thing is when I choose dialogue to physical print within the PDFCreator software the file is printed correctly (on A4).

Could you maybe point me to the right direction what the script should look like?
How do I run a script that prints only that file that was created with PDFCreator?


#4

Hi,

thanks for the feedback, if the document is printed properly when using the printer selection dialogue but not printed properly if the printer was selected in advance, there might be something we can do, as far as I understand both is done by Ghostscript, but there has to be a reason why it only works in one case. We will look into it, but it might take a while and it might not be possible to solve with reasonable effort.
The easiest option regarding the script workaround might be to get SumatraPDF which is a very lightweight PDF viewer capable of silently printing PDFs to a specific printer via command line. Then you just need to point the "run script" action to the SumatraPDF.exe and add the parameters for silent printing. PDFCreator will automatically insert the path of the converted file(s) at the end of the additional parameters.
You can alternatively run any custom script for printing the file.

Best regards

Robin


#5

The workaround is working fine.
I only had to downgrade the sumatrapdf file to 3.0 because Xerox printing problems, but it works now.

Thank you!